summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-11-11 11:07:36 +0000
committerTim Harder <radhermit@gentoo.org>2012-11-11 11:07:36 +0000
commitf5861805f7bb95639b847b02dbef062fdcedb8cd (patch)
tree232efca911c17992f25548484c1605e7399ff66f /dev-python/python-distutils-extra/python-distutils-extra-2.37.ebuild
parentVersion bump. (diff)
downloadhistorical-f5861805f7bb95639b847b02dbef062fdcedb8cd.tar.gz
historical-f5861805f7bb95639b847b02dbef062fdcedb8cd.tar.bz2
historical-f5861805f7bb95639b847b02dbef062fdcedb8cd.zip
Version bump.
Package-Manager: portage-2.2.0_alpha142/cvs/Linux x86_64 Manifest-Sign-Key: 0x4AB3E85B4F064CA3
Diffstat (limited to 'dev-python/python-distutils-extra/python-distutils-extra-2.37.ebuild')
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.37.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.37.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.37.ebuild
new file mode 100644
index 000000000000..3c6fe99fe316
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.37.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/python-distutils-extra-2.37.ebuild,v 1.1 2012/11/11 11:07:34 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.*"
+
+inherit distutils
+
+DESCRIPTION="You can integrate gettext support, themed icons and scrollkeeper based documentation in distutils."
+HOMEPAGE="https://launchpad.net/python-distutils-extra"
+SRC_URI="http://launchpad.net/python-distutils-extra/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+DOCS="doc/FAQ doc/README doc/setup.cfg.example doc/setup.py.example"
+PYTHON_MODNAME="DistUtilsExtra"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable broken tests.
+ sed \
+ -e "s/test_desktop/_&/" \
+ -e "s/test_po(/_&/" \
+ -e "s/test_policykit/_&/" \
+ -e "s/test_requires_provides/_&/" \
+ -i test/auto.py
+}
+
+src_test() {
+ # 5 tests fail with disabled byte-compilation.
+ python_enable_pyc
+
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/auto.py
+ }
+ python_execute_function testing
+
+ python_disable_pyc
+}