summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-07-01 21:33:23 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-07-01 21:33:23 +0000
commit13f47d16ee71af48089496c8487d1e3c02414d69 (patch)
treeb1c7ee7d3f6c42c0a945232a1813612835e8a5d3 /dev-python/pyro
parentRemove old ebuilds. Requested by Arfrever (diff)
downloadhistorical-13f47d16ee71af48089496c8487d1e3c02414d69.tar.gz
historical-13f47d16ee71af48089496c8487d1e3c02414d69.tar.bz2
historical-13f47d16ee71af48089496c8487d1e3c02414d69.zip
Remove old ebuilds. Requested by Arfrever
Package-Manager: portage-2.2.0_alpha42/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/ChangeLog6
-rw-r--r--dev-python/pyro/pyro-3.12.ebuild41
-rw-r--r--dev-python/pyro/pyro-4.1.ebuild57
-rw-r--r--dev-python/pyro/pyro-4.2.ebuild76
-rw-r--r--dev-python/pyro/pyro-4.3.ebuild75
5 files changed, 5 insertions, 250 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index e51af92b7fe5..fa4be5767627 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyro
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.47 2011/07/01 09:22:34 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.48 2011/07/01 21:32:16 hwoarang Exp $
+
+ 01 Jul 2011; Markos Chandras <hwoarang@gentoo.org> -pyro-3.12.ebuild,
+ -pyro-4.1.ebuild, -pyro-4.2.ebuild, -pyro-4.3.ebuild:
+ Remove old ebuilds. Requested by Arfrever
01 Jul 2011; Thomas Kahle <tomka@gentoo.org> pyro-4.4.ebuild:
x86 stable per bug 370507
diff --git a/dev-python/pyro/pyro-3.12.ebuild b/dev-python/pyro/pyro-3.12.ebuild
deleted file mode 100644
index 40c79cd75398..000000000000
--- a/dev-python/pyro/pyro-3.12.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.12.ebuild,v 1.6 2011/04/16 18:37:57 armin76 Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-MY_P="Pyro-${PV}"
-
-DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
-HOMEPAGE="http://www.xs4all.nl/~irmen/pyro3/ http://pypi.python.org/pypi/Pyro"
-SRC_URI="http://www.xs4all.nl/~irmen/pyro3/download/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-DEPEND="!dev-python/pyro:0"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="Pyro"
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/pyro/pyro-4.1.ebuild b/dev-python/pyro/pyro-4.1.ebuild
deleted file mode 100644
index 6ecdbf105833..000000000000
--- a/dev-python/pyro/pyro-4.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.1.ebuild,v 1.5 2011/04/16 18:37:57 armin76 Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4"
-
-inherit distutils
-
-MY_P="Pyro-${PV}"
-
-DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
-HOMEPAGE="http://www.xs4all.nl/~irmen/pyro4/ http://pypi.python.org/pypi/Pyro"
-SRC_URI="http://www.xs4all.nl/~irmen/pyro4/download/${MY_P}-python3.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}-python3"
-
-PYTHON_MODNAME="Pyro"
-
-src_prepare() {
- distutils_src_prepare
-
- # PyroTests.namingtests.NameServerTests.testResolve sometimes hangs.
- sed -e "s/testResolve/_&/" -i tests/PyroTests/namingtests.py || die "sed failed"
-}
-
-src_test() {
- cd tests
-
- testing() {
- "$(PYTHON)" run_testsuite.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/*
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/pyro/pyro-4.2.ebuild b/dev-python/pyro/pyro-4.2.ebuild
deleted file mode 100644
index 041648d32b41..000000000000
--- a/dev-python/pyro/pyro-4.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.2.ebuild,v 1.3 2011/04/16 18:37:57 armin76 Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4"
-
-inherit distutils
-
-MY_P="Pyro4-${PV}"
-
-DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
-HOMEPAGE="http://www.xs4all.nl/~irmen/pyro4/ http://pypi.python.org/pypi/Pyro4"
-SRC_URI="http://www.xs4all.nl/~irmen/pyro4/download/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="Pyro4"
-
-src_prepare() {
- distutils_src_prepare
-
- # Fix tests with >=dev-python/coverage-3.4.
- sed -e 's/omit_prefixes=\["PyroTests"\]/omit=["PyroTests*"]/' -i tests/run_testsuite.py
-
- # Disable tests requiring network connection.
- sed \
- -e "s/testOwnloopBasics/_&/" \
- -e "s/testStartNSfunc/_&/" \
- -i tests/PyroTests/namingtests2.py
- sed -e "s/testServerConnections/_&/" -i tests/PyroTests/servertests.py
- sed \
- -e "s/testBroadcast/_&/" \
- -e "s/testGetIP/_&/" \
- -i tests/PyroTests/sockettests.py
- sed \
- -e "s/testBCstart/_&/" \
- -e "s/testDaemonPyroObj/_&/" \
- -e "s/testLookupAndRegister/_&/" \
- -e "s/testMulti/_&/" \
- -e "s/testRefuseDottedNames/_&/" \
- -e "s/testResolve/_&/" \
- -i tests/PyroTests/namingtests.py
-}
-
-src_test() {
- cd tests
-
- testing() {
- "$(PYTHON)" run_testsuite.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/pyro/pyro-4.3.ebuild b/dev-python/pyro/pyro-4.3.ebuild
deleted file mode 100644
index 1138098e09a8..000000000000
--- a/dev-python/pyro/pyro-4.3.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.3.ebuild,v 1.5 2011/05/28 12:29:52 ranger Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.[45]"
-
-inherit distutils
-
-MY_P="Pyro4-${PV}"
-
-DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
-HOMEPAGE="http://www.xs4all.nl/~irmen/pyro4/ http://www.razorvine.net/python/Pyro http://pypi.python.org/pypi/Pyro4"
-SRC_URI="http://www.xs4all.nl/~irmen/pyro4/download/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-DEPEND="!dev-python/pyro:0"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="Pyro4"
-
-src_prepare() {
- distutils_src_prepare
-
- find -name "._*" -print0 | xargs -0 rm -f
-
- # Disable tests requiring network connection.
- sed \
- -e "s/testOwnloopBasics/_&/" \
- -e "s/testStartNSfunc/_&/" \
- -i tests/PyroTests/namingtests2.py
- sed -e "s/testServerConnections/_&/" -i tests/PyroTests/servertests.py
- sed \
- -e "s/testBroadcast/_&/" \
- -e "s/testGetIP/_&/" \
- -i tests/PyroTests/sockettests.py
- sed \
- -e "s/testBCstart/_&/" \
- -e "s/testDaemonPyroObj/_&/" \
- -e "s/testLookupAndRegister/_&/" \
- -e "s/testMulti/_&/" \
- -e "s/testRefuseDottedNames/_&/" \
- -e "s/testResolve/_&/" \
- -i tests/PyroTests/namingtests.py
-}
-
-src_test() {
- cd tests
-
- testing() {
- "$(PYTHON)" run_testsuite.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
- fi
-}