summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-22 16:55:46 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-22 16:55:46 +0000
commit1204c2df932033a0a4598a9fb06a3b65a6b38065 (patch)
tree0e519edff8140248f4533b62a5bcb24877fe2dab /dev-python/pyosd/pyosd-0.2.14.ebuild
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadhistorical-1204c2df932033a0a4598a9fb06a3b65a6b38065.tar.gz
historical-1204c2df932033a0a4598a9fb06a3b65a6b38065.tar.bz2
historical-1204c2df932033a0a4598a9fb06a3b65a6b38065.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyosd/pyosd-0.2.14.ebuild')
-rw-r--r--dev-python/pyosd/pyosd-0.2.14.ebuild29
1 files changed, 17 insertions, 12 deletions
diff --git a/dev-python/pyosd/pyosd-0.2.14.ebuild b/dev-python/pyosd/pyosd-0.2.14.ebuild
index 5e6d4ccca489..12f5cf3a4c36 100644
--- a/dev-python/pyosd/pyosd-0.2.14.ebuild
+++ b/dev-python/pyosd/pyosd-0.2.14.ebuild
@@ -1,12 +1,18 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyosd/pyosd-0.2.14.ebuild,v 1.8 2007/04/25 06:46:16 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyosd/pyosd-0.2.14.ebuild,v 1.9 2010/07/22 16:55:46 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
DESCRIPTION="PyOSD is a python module for displaying text on your X display, much like the 'On Screen Displays' used on TVs and some monitors."
HOMEPAGE="http://repose.cx/pyosd/"
SRC_URI="http://repose.cx/pyosd/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ia64 ppc x86"
@@ -15,23 +21,22 @@ IUSE="examples"
DEPEND=">=x11-libs/xosd-2.2.4"
RDEPEND="${DEPEND}"
+DOCS="AUTHORS"
+
src_install() {
- DOCS="AUTHORS"
distutils_src_install
+
dohtml pyosd.html
- if use examples ; then
+ if use examples; then
insinto /usr/share/doc/${PF}
- doins -r modules
+ doins -r modules || die "doins failed"
fi
}
pkg_postinst() {
- elog ""
- elog "If you want to run the included daemon"
- elog "you will need to emerge dev-python/twisted."
- elog ""
- elog "Also note that the volume plugin"
- elog "requires media-sound/aumix."
- elog ""
+ distutils_pkg_postinst
+
+ elog "If you want to run the included daemon, you will need to install dev-python/twisted."
+ elog "Also note that the volume plugin requires media-sound/aumix."
}