summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-27 16:13:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-27 16:13:56 +0000
commitfd005cfe46154e20dbf5fc298b6314c000b63294 (patch)
tree1c50f8adc59c3c19f1a3322a0e27d50cdc056e1f /dev-python/pyopenssl
parentFix inheritance order to actually install the plugin. (diff)
downloadhistorical-fd005cfe46154e20dbf5fc298b6314c000b63294.tar.gz
historical-fd005cfe46154e20dbf5fc298b6314c000b63294.tar.bz2
historical-fd005cfe46154e20dbf5fc298b6314c000b63294.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/files/pyopenssl-0.9-tests.patch25
-rw-r--r--dev-python/pyopenssl/pyopenssl-0.9-r1.ebuild70
2 files changed, 0 insertions, 95 deletions
diff --git a/dev-python/pyopenssl/files/pyopenssl-0.9-tests.patch b/dev-python/pyopenssl/files/pyopenssl-0.9-tests.patch
deleted file mode 100644
index 221004b47476..000000000000
--- a/dev-python/pyopenssl/files/pyopenssl-0.9-tests.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- test/test_ssl.py
-+++ test/test_ssl.py
-@@ -10,12 +10,7 @@
- from os import makedirs, symlink
- from os.path import join
-
--try:
-- # Prefer Twisted's TestCase, since it supports things like skips.
-- from twisted.trial.unittest import TestCase
--except ImportError:
-- # Fall back to the stdlib TestCase though, since it kind of works.
-- from unittest import TestCase, main
-+from unittest import TestCase, main
-
- from OpenSSL.crypto import TYPE_RSA, FILETYPE_PEM, PKey, dump_privatekey, load_certificate, load_privatekey
- from OpenSSL.SSL import WantReadError, Context, Connection, Error
-@@ -221,7 +221,7 @@
- self._load_verify_locations_test(None, capath)
-
-
-- def test_set_default_verify_paths(self):
-+ def _test_set_default_verify_paths(self):
- """
- L{Context.set_default_verify_paths} causes the platform-specific CA
- certificate locations to be used for verification purposes.
diff --git a/dev-python/pyopenssl/pyopenssl-0.9-r1.ebuild b/dev-python/pyopenssl/pyopenssl-0.9-r1.ebuild
deleted file mode 100644
index 0b02606eecfc..000000000000
--- a/dev-python/pyopenssl/pyopenssl-0.9-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopenssl/pyopenssl-0.9-r1.ebuild,v 1.11 2009/11/14 17:37:07 armin76 Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-MY_P=${P/openssl/OpenSSL}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Python interface to the OpenSSL library"
-HOMEPAGE="http://pyopenssl.sourceforge.net/ http://pypi.python.org/pypi/pyOpenSSL"
-SRC_URI="mirror://sourceforge/pyopenssl/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x64-solaris"
-IUSE="doc"
-
-RDEPEND=">=dev-libs/openssl-0.9.6g"
-DEPEND="${RDEPEND}
- doc? ( >=dev-tex/latex2html-2002.2 )"
-RESTRICT_PYTHON_ABIS="3.*"
-
-PYTHON_MODNAME="OpenSSL"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-tests.patch"
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- addwrite /var/cache/fonts
- # This one seems to be unnecessary with a recent tetex, but
- # according to bugs it was definitely necessary in the past,
- # so leaving it in.
- addwrite /usr/share/texmf/fonts/pk
-
- cd "${S}"/doc
- make html ps dvi
- fi
-}
-
-src_test() {
- test_package() {
- pushd test > /dev/null
- PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" test_crypto.py || die "test_crypto.py failed"
- PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" test_ssl.py || die "test_ssl.py failed"
- popd > /dev/null
- }
- python_execute_function test_package
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml doc/html/*
- dodoc doc/pyOpenSSL.*
- fi
-
- # Install examples
- docinto examples
- dodoc examples/*
- docinto examples/simple
- dodoc examples/simple/*
-}