summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-23 21:29:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-23 21:29:41 +0000
commit9660df12343be358eef0670685f8a74d9c99ce09 (patch)
treed91d0b0e474a989f7af949dc08e5bc079098b691 /dev-python/pygui/pygui-2.2-r1.ebuild
parentUse virtual/jpeg. (diff)
downloadhistorical-9660df12343be358eef0670685f8a74d9c99ce09.tar.gz
historical-9660df12343be358eef0670685f8a74d9c99ce09.tar.bz2
historical-9660df12343be358eef0670685f8a74d9c99ce09.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pygui/pygui-2.2-r1.ebuild')
-rw-r--r--dev-python/pygui/pygui-2.2-r1.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/dev-python/pygui/pygui-2.2-r1.ebuild b/dev-python/pygui/pygui-2.2-r1.ebuild
index 43c22b121d72..5dca0af3ed6b 100644
--- a/dev-python/pygui/pygui-2.2-r1.ebuild
+++ b/dev-python/pygui/pygui-2.2-r1.ebuild
@@ -1,27 +1,32 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygui/pygui-2.2-r1.ebuild,v 1.2 2010/06/09 21:12:22 patrick Exp $
-EAPI=3
-PYTHON_DEPEND=2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygui/pygui-2.2-r1.ebuild,v 1.3 2010/07/23 21:29:41 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
+
inherit distutils eutils
+MY_P="PyGUI-${PV}"
+
DESCRIPTION="A cross-platform pythonic GUI API"
HOMEPAGE="http://www.cosc.canterbury.ac.nz/greg.ewing/python_gui/"
-
-MY_P=PyGUI-${PV}
-PYTHON_MODNAME=GUI
SRC_URI="http://www.cosc.canterbury.ac.nz/greg.ewing/python_gui/${MY_P}.tar.gz"
+
LICENSE="as-is"
SLOT=0
KEYWORDS="~amd64 ~x86"
IUSE="doc examples"
-RDEPEND="dev-python/pygtk"
-DEPEND=""
+DEPEND="dev-python/pygtk"
+RDEPEND="${DEPEND}"
S="${WORKDIR}"/${MY_P}
+PYTHON_MODNAME="GUI"
+
src_prepare() {
distutils_src_prepare