summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-26 04:27:36 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-26 04:27:36 +0000
commit83cd956741d6a477e61baced6273e40a29c90a61 (patch)
treee53607d4799244c97b71bef51a9285c5fddda7ab /dev-python/paste
parentdev-python/paste: Revert previous commit, shooting too fast, sorry (diff)
downloadhistorical-83cd956741d6a477e61baced6273e40a29c90a61.tar.gz
historical-83cd956741d6a477e61baced6273e40a29c90a61.tar.bz2
historical-83cd956741d6a477e61baced6273e40a29c90a61.zip
Version bump. Fix building with USE="doc" (bug #318757).
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/ChangeLog8
-rw-r--r--dev-python/paste/Manifest4
-rw-r--r--dev-python/paste/paste-1.7.4.ebuild76
3 files changed, 86 insertions, 2 deletions
diff --git a/dev-python/paste/ChangeLog b/dev-python/paste/ChangeLog
index c9c0f99f81fa..466804769f49 100644
--- a/dev-python/paste/ChangeLog
+++ b/dev-python/paste/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/paste
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/ChangeLog,v 1.10 2010/06/26 03:38:16 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/ChangeLog,v 1.11 2010/06/26 04:27:36 arfrever Exp $
+
+*paste-1.7.4 (26 Jun 2010)
+
+ 26 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +paste-1.7.4.ebuild:
+ Version bump. Fix building with USE="doc" (bug #318757).
26 Jun 2010; Sebastian Pipping <sping@gentoo.org> paste-1.7.2.ebuild:
Revert previous commit, shooting too fast, sorry
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index 45ff1bac0652..5eb8f6832b4e 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1,4 +1,6 @@
DIST Paste-1.7.2.tar.gz 373556 RMD160 10deddbb5ef3ccd220c6c0cdb594efd35045fdea SHA1 4c7d6d76ec0fe76d57c525101c6f9ff6ebf4a93c SHA256 67dde086f0aa84c3ec2452cd65d05d19a050ec2ba56483b1614bdbfd82b3b2b8
+DIST Paste-1.7.4.tar.gz 517556 RMD160 35bf95f00a687f619717a2ba571dbc5aae137429 SHA1 df6114f419ce5b162a6e6e29d5a824d699448346 SHA256 3ade96c9ec0406e2f8ef8ebc9521bc00f2dc8865bd4803e995d8adcf8f02010e
EBUILD paste-1.7.2.ebuild 1497 RMD160 7d8027bf8f7ab5aba672c912f1c24dda508b81db SHA1 db2da8a41ebc5c8aa7b69e7ba49acb54a4e71c1b SHA256 1760740cf67e6f1f9ca6255ce496664623f58885aec47f66dc2e1abaa2a15a21
-MISC ChangeLog 1677 RMD160 f9fc8875004c24514af2a1ff26fd33dfd043b2cd SHA1 17d03671e56880002c7d75950232654428ff6f11 SHA256 9a1cb626cf7abfe16ae748792ff164c134f43525fcccef5307cbbef5be5eb11b
+EBUILD paste-1.7.4.ebuild 1906 RMD160 cfdd481792b8e3661a4b25dbc3e6706c6a791450 SHA1 fbe9526489ba540cfcb1368770bcf39c1939f932 SHA256 07c7a2a859987f6d3974a38d69dc990ce36d8ef7f078dae29969b40c2ada2ba4
+MISC ChangeLog 1864 RMD160 a362e43e4a3222bc093846dc8e653d3272e2eff7 SHA1 91e33a1e6040e37b4b7f7174b34c7f73685a3025 SHA256 cfa09d34eb2a0f4ac0879748b0bff386a3a8e65204028e028fab052c8e4aadf3
MISC metadata.xml 635 RMD160 b5ee35a378d2432b7a02585afcc95a7c1db13bbb SHA1 40ba8c8bfbb64413ddf605c5c4f510bbf2e9b2c5 SHA256 9c6189c5e365dc93b62649519e50479cec3d721e4ffb3c4a84cb9632660e6e74
diff --git a/dev-python/paste/paste-1.7.4.ebuild b/dev-python/paste/paste-1.7.4.ebuild
new file mode 100644
index 000000000000..db0be2cc8a7c
--- /dev/null
+++ b/dev-python/paste/paste-1.7.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-1.7.4.ebuild,v 1.1 2010/06/26 04:27:36 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="Paste"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="http://pythonpaste.org http://pypi.python.org/pypi/Paste"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
+IUSE="doc flup openid"
+
+RDEPEND="flup? ( dev-python/flup )
+ openid? ( dev-python/python-openid )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ sed -i \
+ -e '/highlighter/d' \
+ setup.cfg || die "sed failed"
+
+ # Disable failing tests.
+ rm -f tests/test_cgiapp.py
+ sed -e "s/test_logger/_&/" -i tests/test_exceptions/test_reporter.py || die "sed failed"
+ sed \
+ -e "s/test_find_file/_&/" \
+ -e "s/test_deep/_&/" \
+ -e "s/test_static_parser/_&/" \
+ -i tests/test_urlparser.py || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH="." "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
+ fi
+}
+
+# Define custom src_test() due to requirement of PYTHONPATH=".".
+src_test() {
+ testing() {
+ PYTHONPATH="." nosetests
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd build/sphinx/html > /dev/null
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}