summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-07-08 04:10:15 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-07-08 04:10:15 +0000
commit6bc5cb3959847a8c436e1daaa9d321ec92483e9c (patch)
treed1e209d676fd16de4f274368df7f2af803673463 /dev-python/mpmath
parent(#230981) Add sys-fs/e2fsprogs to RDEPEND for libuuid. (diff)
downloadhistorical-6bc5cb3959847a8c436e1daaa9d321ec92483e9c.tar.gz
historical-6bc5cb3959847a8c436e1daaa9d321ec92483e9c.tar.bz2
historical-6bc5cb3959847a8c436e1daaa9d321ec92483e9c.zip
Initial import
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.25-tuxonice-r1 i686
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/ChangeLog10
-rw-r--r--dev-python/mpmath/Manifest4
-rw-r--r--dev-python/mpmath/metadata.xml10
-rw-r--r--dev-python/mpmath/mpmath-0.8.ebuild40
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/mpmath/ChangeLog b/dev-python/mpmath/ChangeLog
new file mode 100644
index 000000000000..d073d99dc7c5
--- /dev/null
+++ b/dev-python/mpmath/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/mpmath
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.1 2008/07/08 04:10:15 grozin Exp $
+
+*mpmath-0.8 (08 Jul 2008)
+
+ 08 Jul 2008; Andrey Grozin <grozin@gentoo.org> +metadata.xml,
+ +mpmath-0.8.ebuild:
+ Initial import
+
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
new file mode 100644
index 000000000000..f6e289d84304
--- /dev/null
+++ b/dev-python/mpmath/Manifest
@@ -0,0 +1,4 @@
+DIST mpmath-0.8.tar.gz 111825 RMD160 cf090d139643d7c10c13a2e12a558f1c44bbe2d2 SHA1 bdb5f2b9efc2ea730b004de3bf2593c74ffbdd34 SHA256 ff25bfa44e96ffe25a69c9de4577f810d953b2936bc57df3009ec5d86474eb67
+EBUILD mpmath-0.8.ebuild 850 RMD160 7bfd691e6968ee96e541f052a7aaabdcf78b26fc SHA1 3a54556f53010e1de27aeb28d84a73eac1069621 SHA256 d11b33e4f3542be365ff308bfcc9a1c7aab2458925fba25d50b91b8aa36c80da
+MISC ChangeLog 338 RMD160 8da53b82e412f4e4a2f9732dc173f9d96ae83f7c SHA1 9b0328b2df1633ad65bd0ff10919df9c8baffa94 SHA256 b18c5ce142fa294b7f787667513772fca9881c721ab5a05b4a73ecaa95b76462
+MISC metadata.xml 365 RMD160 ece7c524ccedeb12b39753fba601dd830c25f8ab SHA1 afc79096300fa102014e4e794fdc20814b25f363 SHA256 d6bb09b59c81f6643741decbdce8d164005673b406d703ce5c2448891b2db2a8
diff --git a/dev-python/mpmath/metadata.xml b/dev-python/mpmath/metadata.xml
new file mode 100644
index 000000000000..180d1643d44c
--- /dev/null
+++ b/dev-python/mpmath/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>A Python library for arbitrary-precision floating-point arithmetic</longdescription>
+</pkgmetadata>
diff --git a/dev-python/mpmath/mpmath-0.8.ebuild b/dev-python/mpmath/mpmath-0.8.ebuild
new file mode 100644
index 000000000000..3d18e2380526
--- /dev/null
+++ b/dev-python/mpmath/mpmath-0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.8.ebuild,v 1.1 2008/07/08 04:10:15 grozin Exp $
+
+NEED_PYTHON=2.4
+inherit distutils
+
+DESCRIPTION="A python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="http://code.google.com/p/mpmath/"
+SRC_URI="http://mpmath.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc examples test"
+
+DEPEND="doc? ( dev-python/sphinx )
+ test? ( dev-python/py )"
+
+src_install() {
+ DOCS="CHANGES"
+ distutils_src_install
+
+ if use doc; then
+ cd doc
+ "${python}" build.py
+ dohtml -r build/*
+ cd ..
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demo/*
+ fi
+}
+
+src_test() {
+ cd mpmath/tests
+ py.test || die "tests failed"
+}