summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-06 15:31:49 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-06 15:31:49 +0000
commit7abbee086339cbfd79ef20afad34d120d5659c01 (patch)
tree1266eb4c7159380e419bb1cfc6b874b0fed9964f /dev-python/libcloud
parentRemove ControlGroup attribute, which is unsupported as of systemd-205. (diff)
downloadhistorical-7abbee086339cbfd79ef20afad34d120d5659c01.tar.gz
historical-7abbee086339cbfd79ef20afad34d120d5659c01.tar.bz2
historical-7abbee086339cbfd79ef20afad34d120d5659c01.zip
revbump; migrate -> distutils-r1, add missing (optional) test dep
Package-Manager: portage-2.1.11.63/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/libcloud')
-rw-r--r--dev-python/libcloud/ChangeLog7
-rw-r--r--dev-python/libcloud/libcloud-0.12.4-r1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/libcloud/ChangeLog b/dev-python/libcloud/ChangeLog
index a711a46e31bd..c0a2f5fad6fa 100644
--- a/dev-python/libcloud/ChangeLog
+++ b/dev-python/libcloud/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/libcloud
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/ChangeLog,v 1.9 2013/05/02 04:11:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/ChangeLog,v 1.10 2013/07/06 15:31:49 idella4 Exp $
+
+*libcloud-0.12.4-r1 (06 Jul 2013)
+
+ 06 Jul 2013; Ian Delaney <idella4@gentoo.org> +libcloud-0.12.4-r1.ebuild:
+ revbump; migrate -> distutils-r1, add missing (optional) test dep
*libcloud-0.12.4 (02 May 2013)
diff --git a/dev-python/libcloud/libcloud-0.12.4-r1.ebuild b/dev-python/libcloud/libcloud-0.12.4-r1.ebuild
new file mode 100644
index 000000000000..bd78c14f933a
--- /dev/null
+++ b/dev-python/libcloud/libcloud-0.12.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libcloud/libcloud-0.12.4-r1.ebuild,v 1.1 2013/07/06 15:31:49 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} pypy2_0 )
+PYTHON_REQ_USE="ssl"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="http://libcloud.apache.org/index.html"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/lockfile[${PYTHON_USEDEP}] )"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+S="${WORKDIR}/apache-${P}"
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples
+ mv example_*.py examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+ esetup.py test
+ popd > /dev/null
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}