summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-01 23:16:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-01 23:16:44 +0000
commit1c44abe829c69236022619be28fa3972ad8c1b02 (patch)
treebe8731399cc9ae226de5dcc7291ce0d7093f490d /dev-python/kid
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadhistorical-1c44abe829c69236022619be28fa3972ad8c1b02.tar.gz
historical-1c44abe829c69236022619be28fa3972ad8c1b02.tar.bz2
historical-1c44abe829c69236022619be28fa3972ad8c1b02.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-14471-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/kid')
-rw-r--r--dev-python/kid/ChangeLog8
-rw-r--r--dev-python/kid/kid-0.9.6.ebuild36
2 files changed, 24 insertions, 20 deletions
diff --git a/dev-python/kid/ChangeLog b/dev-python/kid/ChangeLog
index a8f7f891d13b..c885dbf6df51 100644
--- a/dev-python/kid/ChangeLog
+++ b/dev-python/kid/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/kid
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/ChangeLog,v 1.13 2007/07/17 07:35:25 lucass Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/ChangeLog,v 1.14 2009/10/01 23:12:25 arfrever Exp $
+
+ 01 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ kid-0.9.6.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*kid-0.9.6 (17 Jul 2007)
diff --git a/dev-python/kid/kid-0.9.6.ebuild b/dev-python/kid/kid-0.9.6.ebuild
index 20c171769731..8e1066ab479b 100644
--- a/dev-python/kid/kid-0.9.6.ebuild
+++ b/dev-python/kid/kid-0.9.6.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/kid-0.9.6.ebuild,v 1.1 2007/07/17 07:35:25 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/kid-0.9.6.ebuild,v 1.2 2009/10/01 23:12:25 arfrever Exp $
-NEED_PYTHON=2.3
+EAPI="2"
+
+NEED_PYTHON="2.5"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -15,25 +18,26 @@ LICENSE="MIT"
SLOT="0"
IUSE="doc examples"
-RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/elementtree )"
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-0.6_rc6
+RDEPEND=""
+DEPEND=">=dev-python/setuptools-0.6_rc6
doc? ( dev-python/docutils )"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
-src_test() {
- # We have to move the build folder out of the way to make the tests work
- mv build build.bak
- PYTHONPATH="." "${python}" run_tests.py -x || die "tests failed"
- mv build.bak build
-}
+DOCS="HISTORY RELEASING"
src_compile() {
distutils_src_compile
use doc && emake -C doc
}
+src_test() {
+ testing() {
+ PYTHONPATH="." "$(PYTHON)" run_tests.py -x
+ }
+ python_execute_function testing
+}
+
src_install() {
- DOCS="HISTORY RELEASING"
distutils_src_install
dobin bin/*
@@ -41,12 +45,8 @@ src_install() {
dodoc doc/*.txt
use doc && dohtml doc/*.{html,css}
- if use examples ; then
+ if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples
fi
}
-
-pkg_postinst() {
- elog "Installing dev-python/celementtree may enhance performance."
-}