summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Thode <prometheanfire@gentoo.org>2013-12-11 16:18:30 +0000
committerMatt Thode <prometheanfire@gentoo.org>2013-12-11 16:18:30 +0000
commit26244cf4bb14806b6555b4a4ac23b8749145c772 (patch)
tree88ff870a29412bba83bb45ee83d8e12bde7ff0b2 /dev-python/fixtures/fixtures-0.3.14-r1.ebuild
parentupdate maintainer (diff)
downloadhistorical-26244cf4bb14806b6555b4a4ac23b8749145c772.tar.gz
historical-26244cf4bb14806b6555b4a4ac23b8749145c772.tar.bz2
historical-26244cf4bb14806b6555b4a4ac23b8749145c772.zip
fixtures-0.3.14-r1 for bug 493926
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0x2471EB3E40AC5AC3
Diffstat (limited to 'dev-python/fixtures/fixtures-0.3.14-r1.ebuild')
-rw-r--r--dev-python/fixtures/fixtures-0.3.14-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/fixtures/fixtures-0.3.14-r1.ebuild b/dev-python/fixtures/fixtures-0.3.14-r1.ebuild
new file mode 100644
index 000000000000..b1a5fa780a12
--- /dev/null
+++ b/dev-python/fixtures/fixtures-0.3.14-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fixtures/fixtures-0.3.14-r1.ebuild,v 1.1 2013/12/11 16:18:21 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more."
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/testtools-0.9.22"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ pushd "${BUILD_DIR}"/ > /dev/null
+ ln -sf ../README .
+ nosetests lib/${PN}/tests/test_*.py || die "Tests failed under ${EPYTHON}"
+}