summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-22 21:56:47 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-22 21:56:47 +0000
commitcdee22748f8a5734cd2cb2dbd4829c21edbe638e (patch)
tree9f6e4a03d66d8c5dba7b342918e07cb8896096ef /dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r2.ebuild
parentRestore stable keywords. (diff)
downloadhistorical-cdee22748f8a5734cd2cb2dbd4829c21edbe638e.tar.gz
historical-cdee22748f8a5734cd2cb2dbd4829c21edbe638e.tar.bz2
historical-cdee22748f8a5734cd2cb2dbd4829c21edbe638e.zip
Convert to distutils-r1.
Package-Manager: portage-2.2.0_alpha176/cvs/Linux x86_64 Manifest-Sign-Key: 0x0BBEEA1FEA4843A4
Diffstat (limited to 'dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r2.ebuild')
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r2.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r2.ebuild
new file mode 100644
index 000000000000..be3242d0c929
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r2.ebuild,v 1.1 2013/05/22 21:56:45 floppym Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{3_1,3_2,3_3} )
+
+inherit distutils-r1 eutils
+
+MY_PN="BeautifulSoup"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/ http://pypi.python.org/pypi/BeautifulSoup"
+SRC_URI="http://www.crummy.com/software/${MY_PN}/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="python-3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!dev-python/beautifulsoup:0"
+
+S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}/${P}-python-3.patch" )
+
+python_test() {
+ "${PYTHON}" BeautifulSoupTests.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Delete useless files.
+ rm -r "${ED%/}/usr/bin" || die
+}