summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-26 15:22:55 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-26 15:22:55 +0000
commit53fac17d69752fdc0fa2cd1f4ea799191df5d66a (patch)
tree4722d6a03498102e0644b733c207e39fea25510d /dev-python/RecSQL/RecSQL-0.7.8.ebuild
parentUse udev.eclass for udev rules installation. (diff)
downloadhistorical-53fac17d69752fdc0fa2cd1f4ea799191df5d66a.tar.gz
historical-53fac17d69752fdc0fa2cd1f4ea799191df5d66a.tar.bz2
historical-53fac17d69752fdc0fa2cd1f4ea799191df5d66a.zip
dev-python/RecSQL: Enhance python r1 eclass usage
Package-Manager: portage-2.2.0_alpha169/cvs/Linux x86_64 Manifest-Sign-Key: 0x8009D6F070EB7916
Diffstat (limited to 'dev-python/RecSQL/RecSQL-0.7.8.ebuild')
-rw-r--r--dev-python/RecSQL/RecSQL-0.7.8.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/RecSQL/RecSQL-0.7.8.ebuild b/dev-python/RecSQL/RecSQL-0.7.8.ebuild
index 0fe5f3c63dec..e73a2734db78 100644
--- a/dev-python/RecSQL/RecSQL-0.7.8.ebuild
+++ b/dev-python/RecSQL/RecSQL-0.7.8.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/RecSQL/RecSQL-0.7.8.ebuild,v 1.2 2013/03/25 11:44:16 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/RecSQL/RecSQL-0.7.8.ebuild,v 1.3 2013/03/26 15:22:53 jlec Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+PYTHON_REQ_USE="sqlite"
if [[ $PV = *9999* ]]; then
scm_eclass=git-2
@@ -21,13 +22,12 @@ fi
inherit eutils distutils-r1 ${scm_eclass}
-DESCRIPTION="RecSQL - simple SQL analysis of python records"
+DESCRIPTION="Simple SQL analysis of python records"
HOMEPAGE="http://orbeckst.github.com/RecSQL/"
+
LICENSE="GPL-3"
SLOT="0"
IUSE=""
-DEPEND="
- dev-lang/python[sqlite]
- dev-python/numpy"
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"