summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-12-07 02:43:53 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-12-07 02:43:53 +0000
commitd27be69e72589f1f7d2f4a3de8c36c8784b99e9e (patch)
treee9e6bd5eec51e9c89fb8d3376884002b42fcf2eb /dev-python/PyQt
parentTry pulling get_number_of_jobs(), on suggestion of Michael Sterrett <mr_bones... (diff)
downloadhistorical-d27be69e72589f1f7d2f4a3de8c36c8784b99e9e.tar.gz
historical-d27be69e72589f1f7d2f4a3de8c36c8784b99e9e.tar.bz2
historical-d27be69e72589f1f7d2f4a3de8c36c8784b99e9e.zip
Moving sys-devel/libtool out of RDEPEND and into DEPEND
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/ChangeLog6
-rw-r--r--dev-python/PyQt/PyQt-3.11.ebuild8
-rw-r--r--dev-python/PyQt/PyQt-3.12.ebuild9
-rw-r--r--dev-python/PyQt/PyQt-3.13.ebuild9
-rw-r--r--dev-python/PyQt/PyQt-3.8.1.ebuild8
5 files changed, 27 insertions, 13 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index b0f9d4482b71..4ab864056f69 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.45 2004/11/23 19:16:06 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.46 2004/12/07 02:43:53 caleb Exp $
+
+ 06 Dec 2004; Caleb Tennis <caleb@gentoo.org> PyQt-3.11.ebuild,
+ PyQt-3.12.ebuild, PyQt-3.13.ebuild, PyQt-3.8.1.ebuild:
+ Moving sys-devel/libtool out of RDEPEND and into DDEPEND
23 Nov 2004; Carsten Lohrke <carlo@gentoo.org> PyQt-3.13.ebuild:
stable on x86
diff --git a/dev-python/PyQt/PyQt-3.11.ebuild b/dev-python/PyQt/PyQt-3.11.ebuild
index 9be03409719a..b453c834e119 100644
--- a/dev-python/PyQt/PyQt-3.11.ebuild
+++ b/dev-python/PyQt/PyQt-3.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.11.ebuild,v 1.6 2004/08/20 01:27:00 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.11.ebuild,v 1.7 2004/12/07 02:43:53 caleb Exp $
inherit distutils
@@ -14,13 +14,15 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ppc ~sparc ~alpha amd64"
-DEPEND="virtual/libc
- sys-devel/libtool
+RDEPEND="virtual/libc
x11-libs/qt
dev-lang/python
>=dev-python/sip-3.10.1
<=dev-python/qscintilla-1.54"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
src_compile() {
distutils_python_version
diff --git a/dev-python/PyQt/PyQt-3.12.ebuild b/dev-python/PyQt/PyQt-3.12.ebuild
index d0ef6db60710..55f884b10046 100644
--- a/dev-python/PyQt/PyQt-3.12.ebuild
+++ b/dev-python/PyQt/PyQt-3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.12.ebuild,v 1.8 2004/09/22 22:57:20 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.12.ebuild,v 1.9 2004/12/07 02:43:53 caleb Exp $
inherit distutils
@@ -17,13 +17,16 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc -alpha amd64"
-DEPEND="virtual/libc
- sys-devel/libtool
+RDEPEND="virtual/libc
x11-libs/qt
dev-lang/python
>=dev-python/sip-3.10.2
<=dev-python/qscintilla-1.60"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+
src_compile() {
distutils_python_version
addpredict ${QTDIR}/etc/settings
diff --git a/dev-python/PyQt/PyQt-3.13.ebuild b/dev-python/PyQt/PyQt-3.13.ebuild
index bf2d6e8f71e3..421633796a91 100644
--- a/dev-python/PyQt/PyQt-3.13.ebuild
+++ b/dev-python/PyQt/PyQt-3.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.13.ebuild,v 1.3 2004/11/23 19:16:06 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.13.ebuild,v 1.4 2004/12/07 02:43:53 caleb Exp $
inherit distutils
@@ -16,13 +16,16 @@ LICENSE="GPL-2"
KEYWORDS="x86 ~ppc ~sparc -alpha ~amd64 ~ppc64"
IUSE="doc"
-DEPEND="virtual/libc
- sys-devel/libtool
+RDEPEND="virtual/libc
x11-libs/qt
dev-lang/python
>=dev-python/sip-3.10.2
<=dev-python/qscintilla-1.61"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+
src_compile() {
distutils_python_version
addpredict ${QTDIR}/etc/settings
diff --git a/dev-python/PyQt/PyQt-3.8.1.ebuild b/dev-python/PyQt/PyQt-3.8.1.ebuild
index 45edc5157171..35fb5ce3ca3b 100644
--- a/dev-python/PyQt/PyQt-3.8.1.ebuild
+++ b/dev-python/PyQt/PyQt-3.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.8.1.ebuild,v 1.11 2004/07/02 04:24:13 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.8.1.ebuild,v 1.12 2004/12/07 02:43:53 caleb Exp $
inherit distutils eutils
@@ -19,13 +19,15 @@ PV_MAJOR=${PV/.*/}
PV_MINOR=${PV#${PV_MAJOR}.}
PV_MINOR=${PV_MINOR/.*}
-DEPEND="virtual/libc
- sys-devel/libtool
+RDEPEND="virtual/libc
x11-libs/qt
dev-lang/python
=dev-python/sip-${PV_MAJOR}.${PV_MINOR}*
>=dev-python/qscintilla-1.53"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
src_unpack() {
unpack PyQt-x11-gpl-${PV}.tar.gz
cd ${S}