summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-10-18 06:27:19 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-10-18 06:27:19 +0000
commit653415756e73228e47c4f5e75cc0628abdb3c0be (patch)
tree8b778c08124ee8a1172fe03e6fb5ffdde70a67f4 /dev-php
parentReadded png support. fixes #8882 (diff)
downloadhistorical-653415756e73228e47c4f5e75cc0628abdb3c0be.tar.gz
historical-653415756e73228e47c4f5e75cc0628abdb3c0be.tar.bz2
historical-653415756e73228e47c4f5e75cc0628abdb3c0be.zip
make sure pdflib and libgd are not merged together. fixes #8883
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/mod_php-4.2.2-r1.ebuild6
-rw-r--r--dev-php/mod_php/mod_php-4.2.3.ebuild6
-rw-r--r--dev-php/php/php-4.2.2-r1.ebuild5
-rw-r--r--dev-php/php/php-4.2.3.ebuild5
4 files changed, 10 insertions, 12 deletions
diff --git a/dev-php/mod_php/mod_php-4.2.2-r1.ebuild b/dev-php/mod_php/mod_php-4.2.2-r1.ebuild
index 00c7d5508dd5..34613bf64e44 100644
--- a/dev-php/mod_php/mod_php-4.2.2-r1.ebuild
+++ b/dev-php/mod_php/mod_php-4.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.2.2-r1.ebuild,v 1.13 2002/10/05 05:39:11 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.2.2-r1.ebuild,v 1.14 2002/10/18 06:27:19 rphillips Exp $
IUSE="freetype postgres tiff libwww nls jpeg ssl gd oci8 mysql X gdbm curl imap png xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb firebird pam"
@@ -110,14 +110,14 @@ src_compile() {
use odbc && myconf="${myconf} --with-unixODBC=/usr"
use ldap && myconf="${myconf} --with-ldap"
use firebird && myconf="${myconf} --with-interbase=/opt/interbase"
- use gd && myconf="${myconf} --with-gd"
use freetype && myconf="${myconf} --with-ttf --with-t1lib"
- use png && myconf="${myconf} --with-png-dir=/usr"
# rphillips - should fix #2708
if [ "`use pdflib`" ] ; then
myconf="${myconf} --with-pdflib=/usr"
else
+ use gd && myconf="${myconf} --with-gd"
+ use png && myconf="${myconf} --with-png-dir=/usr"
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
fi
diff --git a/dev-php/mod_php/mod_php-4.2.3.ebuild b/dev-php/mod_php/mod_php-4.2.3.ebuild
index f7d20a9c8e80..949c60b157bf 100644
--- a/dev-php/mod_php/mod_php-4.2.3.ebuild
+++ b/dev-php/mod_php/mod_php-4.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.2.3.ebuild,v 1.3 2002/10/05 05:39:11 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.2.3.ebuild,v 1.4 2002/10/18 06:27:19 rphillips Exp $
IUSE="freetype postgres tiff libwww nls jpeg ssl gd oci8 mysql X gdbm curl imap png xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
@@ -112,14 +112,14 @@ src_compile() {
use odbc && myconf="${myconf} --with-unixODBC=/usr"
use ldap && myconf="${myconf} --with-ldap"
use firebird && myconf="${myconf} --with-interbase=/opt/interbase"
- use gd && myconf="${myconf} --with-gd"
use freetype && myconf="${myconf} --with-ttf --with-t1lib"
- use png && myconf="${myconf} --with-png-dir=/usr"
# rphillips - should fix #2708
if [ "`use pdflib`" ] ; then
myconf="${myconf} --with-pdflib=/usr"
else
+ use gd && myconf="${myconf} --with-gd"
+ use png && myconf="${myconf} --with-png-dir=/usr"
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
fi
diff --git a/dev-php/php/php-4.2.2-r1.ebuild b/dev-php/php/php-4.2.2-r1.ebuild
index 9f523a53d81b..0879063ab8a0 100644
--- a/dev-php/php/php-4.2.2-r1.ebuild
+++ b/dev-php/php/php-4.2.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Update: Roman Weber <gentoo@gonzo.ch>
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.2-r1.ebuild,v 1.15 2002/10/18 06:21:35 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.2-r1.ebuild,v 1.16 2002/10/18 06:25:13 rphillips Exp $
IUSE="freetype postgres tiff libwww nls jpeg readline ssl gd #java mysql X gdbm curl imap png xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb firebird pam oci8"
@@ -102,14 +102,13 @@ src_compile() {
use odbc && myconf="${myconf} --with-unixODBC=/usr"
use ldap && myconf="${myconf} --with-ldap"
use firebird && myconf="${myconf} --with-interbase=/opt/interbase"
- use gd && myconf="${myconf} --with-gd"
use freetype && myconf="${myconf} --with-ttf --with-t1lib"
- use tiff && myconf="${myconf} --with-tiff-dir=/usr"
# rphillips - should fix #2708
if [ "`use pdflib`" ] ; then
myconf="${myconf} --enable-pdflib=/usr"
else
+ use gd && myconf="${myconf} --with-gd"
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
use png && myconf="${myconf} --with-png-dir=/usr"
diff --git a/dev-php/php/php-4.2.3.ebuild b/dev-php/php/php-4.2.3.ebuild
index fcbc4802451a..51b91fde9fc6 100644
--- a/dev-php/php/php-4.2.3.ebuild
+++ b/dev-php/php/php-4.2.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Update: Roman Weber <gentoo@gonzo.ch>
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.3.ebuild,v 1.6 2002/10/18 06:21:35 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.3.ebuild,v 1.7 2002/10/18 06:25:13 rphillips Exp $
IUSE="freetype postgres tiff libwww nls jpeg readline ssl gd oci8 mysql X gdbm curl imap png xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
@@ -106,14 +106,13 @@ src_compile() {
use odbc && myconf="${myconf} --with-unixODBC=/usr"
use ldap && myconf="${myconf} --with-ldap"
use firebird && myconf="${myconf} --with-interbase=/opt/interbase"
- use gd && myconf="${myconf} --with-gd"
use freetype && myconf="${myconf} --with-ttf --with-t1lib"
- use tiff && myconf="${myconf} --with-tiff-dir=/usr"
# rphillips - should fix #2708
if [ "`use pdflib`" ] ; then
myconf="${myconf} --enable-pdflib=/usr"
else
+ use gd && myconf="${myconf} --with-gd"
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
use png && myconf="${myconf} --with-png-dir=/usr"