summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-12-24 14:54:13 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-12-24 14:54:13 +0000
commita15945cdab2719cb95424b79d14c485f1c5fb149 (patch)
treee10d80bad50b8ad80426222dcd0a318771108c71 /dev-php5
parentGet rid of sql dep and assistant build, it's in another package now (diff)
downloadhistorical-a15945cdab2719cb95424b79d14c485f1c5fb149.tar.gz
historical-a15945cdab2719cb95424b79d14c485f1c5fb149.tar.bz2
historical-a15945cdab2719cb95424b79d14c485f1c5fb149.zip
Version bump from the php-overlay
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/ZendFramework/ChangeLog12
-rw-r--r--dev-php5/ZendFramework/ZendFramework-1.0.3.ebuild48
-rw-r--r--dev-php5/ZendFramework/files/digest-ZendFramework-1.0.39
-rw-r--r--dev-php5/jpgraph/ChangeLog10
-rw-r--r--dev-php5/jpgraph/files/digest-jpgraph-2.33
-rw-r--r--dev-php5/jpgraph/jpgraph-2.3.ebuild90
-rw-r--r--dev-php5/pecl-yaz/ChangeLog10
-rw-r--r--dev-php5/pecl-yaz/files/digest-pecl-yaz-1.0.133
-rw-r--r--dev-php5/pecl-yaz/pecl-yaz-1.0.13.ebuild27
-rw-r--r--dev-php5/php-java-bridge/ChangeLog12
-rw-r--r--dev-php5/php-java-bridge/files/digest-php-java-bridge-4.3.23
-rw-r--r--dev-php5/php-java-bridge/php-java-bridge-4.3.2.ebuild54
-rw-r--r--dev-php5/phpunit/ChangeLog10
-rw-r--r--dev-php5/phpunit/files/digest-phpunit-3.2.53
-rw-r--r--dev-php5/phpunit/phpunit-3.2.5.ebuild35
-rw-r--r--dev-php5/propel-generator/ChangeLog12
-rw-r--r--dev-php5/propel-generator/files/digest-propel-generator-1.3.0_beta33
-rw-r--r--dev-php5/propel-generator/propel-generator-1.3.0_beta3.ebuild26
-rw-r--r--dev-php5/propel-runtime/ChangeLog12
-rw-r--r--dev-php5/propel-runtime/files/digest-propel-runtime-1.3.0_beta33
-rw-r--r--dev-php5/propel-runtime/propel-runtime-1.3.0_beta3.ebuild25
-rw-r--r--dev-php5/propel/ChangeLog10
-rw-r--r--dev-php5/propel/files/digest-propel-1.3.0_beta30
-rw-r--r--dev-php5/propel/propel-1.3.0_beta3.ebuild15
-rw-r--r--dev-php5/symfony/ChangeLog10
-rw-r--r--dev-php5/symfony/files/digest-symfony-1.0.103
-rw-r--r--dev-php5/symfony/symfony-1.0.10.ebuild24
27 files changed, 463 insertions, 9 deletions
diff --git a/dev-php5/ZendFramework/ChangeLog b/dev-php5/ZendFramework/ChangeLog
index 350d6334583c..f534b3d77713 100644
--- a/dev-php5/ZendFramework/ChangeLog
+++ b/dev-php5/ZendFramework/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-php5/ZendFramework
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ChangeLog,v 1.21 2007/10/15 18:10:53 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ChangeLog,v 1.22 2007/12/24 14:54:13 armin76 Exp $
+
+*ZendFramework-1.0.3 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org>
+ +ZendFramework-1.0.3.ebuild:
+ Version bump from the php-overlay
+
+ 21 Dec 2007; Jakub Moc <jakub@gentoo.org>
+ +ZendFramework-1.0.3.ebuild:
+ Version bump, fix LICENSE, do not dodoc INSTALL and LICENSE, fix docs location
15 Oct 2007; Bjarke Istrup Pedersen <gurligebis@gentoo.org>
ZendFramework-1.0.2.ebuild:
diff --git a/dev-php5/ZendFramework/ZendFramework-1.0.3.ebuild b/dev-php5/ZendFramework/ZendFramework-1.0.3.ebuild
new file mode 100644
index 000000000000..dd52af1466ad
--- /dev/null
+++ b/dev-php5/ZendFramework/ZendFramework-1.0.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ZendFramework-1.0.3.ebuild,v 1.1 2007/12/24 14:54:13 armin76 Exp $
+
+PHP_LIB_NAME="Zend"
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Zend Framework is a high quality and open source framework for developing Web Applications and Web Services with PHP 5."
+HOMEPAGE="http://framework.zend.com/"
+SRC_URI="http://framework.zend.com/releases/${P}/${P}.tar.gz
+ doc? (
+ http://framework.zend.com/releases/${P}/${P}-apidoc.tar.gz
+ http://framework.zend.com/releases/${P}/${P}-manual-en.tar.gz )"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+src_install() {
+ php-lib-r1_src_install library/Zend `cd library/Zend ; find . -type f -print`
+
+ # Incubator has been removed, keeping in case it comes back
+ #php-lib-r1_src_install incubator/library/Zend `cd incubator/library/Zend ; find . -type f -print`
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r demos
+ fi
+
+ if use doc ; then
+ dodoc {NEWS,README,VERSION}.txt
+ dohtml -r documentation/*
+ fi
+}
+
+pkg_postinst() {
+ ewarn "As of version 0.9.3, the Zend.php class has been removed."
+ ewarn "For more info, please take a look at the manual at:"
+ ewarn "http://framework.zend.com/manual"
+ ebeep
+}
diff --git a/dev-php5/ZendFramework/files/digest-ZendFramework-1.0.3 b/dev-php5/ZendFramework/files/digest-ZendFramework-1.0.3
new file mode 100644
index 000000000000..79c53f2b4e18
--- /dev/null
+++ b/dev-php5/ZendFramework/files/digest-ZendFramework-1.0.3
@@ -0,0 +1,9 @@
+MD5 b9e33d037771a49e35e59fbda9a36522 ZendFramework-1.0.3-apidoc.tar.gz 2966622
+RMD160 943de7eabff2981d7a37e9550107cf1070bb33f4 ZendFramework-1.0.3-apidoc.tar.gz 2966622
+SHA256 6f620dc92c94080c1d7c9c4ac95e8385b64e00518a733fbd4df54a0921a8f5e1 ZendFramework-1.0.3-apidoc.tar.gz 2966622
+MD5 4d42a67c50c1f17162572086de1b6676 ZendFramework-1.0.3-manual-en.tar.gz 644003
+RMD160 65f48a35437526a8262701af4365d4d83a090ae2 ZendFramework-1.0.3-manual-en.tar.gz 644003
+SHA256 d5461483c3d7e9562f01e95d39434157a47b087611cd8c4dcfd8f413b096a09b ZendFramework-1.0.3-manual-en.tar.gz 644003
+MD5 f44da5090c9a461b20372e64574b30ff ZendFramework-1.0.3.tar.gz 3918956
+RMD160 94db4d663f1ae950b64d2d819f06850fac20d5a6 ZendFramework-1.0.3.tar.gz 3918956
+SHA256 b685c9314b3568b31d1c0957ea045f732b8a268807e0bb1aec185da18cbac8a9 ZendFramework-1.0.3.tar.gz 3918956
diff --git a/dev-php5/jpgraph/ChangeLog b/dev-php5/jpgraph/ChangeLog
index edd95ebc9b72..7d8b647675a1 100644
--- a/dev-php5/jpgraph/ChangeLog
+++ b/dev-php5/jpgraph/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/jpgraph
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/jpgraph/ChangeLog,v 1.26 2007/11/14 15:27:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/jpgraph/ChangeLog,v 1.27 2007/12/24 14:45:33 armin76 Exp $
+
+*jpgraph-2.3 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> +jpgraph-2.3.ebuild:
+ Version bump from the php-overlay
+
+ 21 Dec 2007; Jakub Moc <jakub@gentoo.org> +jpgraph-2.3.ebuild:
+ Version bump
14 Nov 2007; Jeroen Roovers <jer@gentoo.org> jpgraph-2.2.ebuild:
Stable for HPPA (bug #198564).
diff --git a/dev-php5/jpgraph/files/digest-jpgraph-2.3 b/dev-php5/jpgraph/files/digest-jpgraph-2.3
new file mode 100644
index 000000000000..8e29dced6388
--- /dev/null
+++ b/dev-php5/jpgraph/files/digest-jpgraph-2.3
@@ -0,0 +1,3 @@
+MD5 a56d345810733aee2829cf56924a3f1a jpgraph-2.3.tar.gz 4619908
+RMD160 dcebe1591bc9ccd1a24d454b8890416d06e4ef4b jpgraph-2.3.tar.gz 4619908
+SHA256 f149ed7a45e4e2e8045f9ccf3f8342153d25766ffc0f0f7242cfcf7185b88fb9 jpgraph-2.3.tar.gz 4619908
diff --git a/dev-php5/jpgraph/jpgraph-2.3.ebuild b/dev-php5/jpgraph/jpgraph-2.3.ebuild
new file mode 100644
index 000000000000..f58c414c0a97
--- /dev/null
+++ b/dev-php5/jpgraph/jpgraph-2.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/jpgraph/jpgraph-2.3.ebuild,v 1.1 2007/12/24 14:45:33 armin76 Exp $
+
+inherit php-lib-r1 eutils
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+DESCRIPTION="Fully OO graph drawing library for PHP."
+HOMEPAGE="http://www.aditus.nu/jpgraph/"
+SRC_URI="http://hem.bredband.net/jpgraph2/${P}.tar.gz"
+LICENSE="QPL-1.0"
+SLOT="0"
+IUSE="truetype"
+
+DEPEND=""
+RDEPEND="truetype? ( media-fonts/corefonts )"
+
+need_php_by_category
+
+[[ -z "${JPGRAPH_CACHEDIR}" ]] && JPGRAPH_CACHEDIR="/var/cache/jpgraph-php5/"
+
+pkg_setup() {
+ has_php
+
+ # we need the PHP GD functionality
+ require_gd
+
+ # check to wich user:group the cache dir will go
+ if has_version "www-servers/apache" ; then
+ HTTPD_USER="apache"
+ HTTPD_GROUP="apache"
+ einfo "Configuring ${JPGRAPH_CACHEDIR} for Apache."
+ else
+ HTTPD_USER="${HTTPD_USER:-root}"
+ HTTPD_GROUP="${HTTPD_GROUP:-root}"
+ ewarn "No Apache webserver detected - ${JPGRAPH_CACHEDIR} will be"
+ ewarn "owned by ${HTTPD_USER}:${HTTPD_GROUP} instead."
+ ewarn "It this is not what you want, you can define"
+ ewarn "HTTPD_USER and HTTPD_GROUP variables and re-emerge ${PN}."
+ epause 3
+ fi
+}
+
+src_install() {
+ # some patches to adapt the config to Gentoo
+ einfo "Patching jpg-config.inc.php"
+
+ # patch 1:
+ # make jpgraph use the correct group for file permissions
+
+ sed -i "s|^DEFINE(\"CACHE_FILE_GROUP\",\"wwwadmin\");|DEFINE(\"CACHE_FILE_GROUP\",\"${HTTPD_GROUP}\");|" src/jpg-config.inc.php \
+ || die "sed failed in patch 1"
+
+ # patch 2:
+ # make jpgraph use the correct directory for caching
+
+ sed -i "s|.*DEFINE(\"CACHE_DIR\",\"/tmp/jpgraph_cache/\");|DEFINE(\"CACHE_DIR\",\"${JPGRAPH_CACHEDIR}\");|" src/jpg-config.inc.php \
+ || die "sed failed in patch 2"
+
+ # patch 3:
+ # make jpgraph use the correct directory for the corefonts if the truetype USE flag is set
+
+ if use truetype ; then
+ sed -i "s|.*DEFINE(\"TTF_DIR\",\"/usr/X11R6/lib/X11/fonts/truetype/\");|DEFINE(\"TTF_DIR\",\"/usr/share/fonts/corefonts/\");|" src/jpg-config.inc.php \
+ || die "sed failed in patch 3"
+ fi
+
+ # patch 4:
+ # disable READ_CACHE in jpgraph
+
+ sed -i "s|^DEFINE(\"READ_CACHE\",true);|DEFINE(\"READ_CACHE\",false);|" src/jpg-config.inc.php \
+ || die "sed failed in patch 4"
+
+ # install php files
+ einfo "Building list of files to install"
+ php-lib-r1_src_install src `cd src ; find . -type f -print`
+
+ # install documentation
+ einfo "Installing documentation"
+ dodoc-php README
+ insinto /usr/share/doc/${CATEGORY}/${PF}
+ doins -r docs/*
+
+ # setup the cache dir
+ einfo "Setting up the cache dir"
+ keepdir "${JPGRAPH_CACHEDIR}"
+ fowners ${HTTPD_USER}:${HTTPD_GROUP} "${JPGRAPH_CACHEDIR}"
+ fperms 750 "${JPGRAPH_CACHEDIR}"
+}
diff --git a/dev-php5/pecl-yaz/ChangeLog b/dev-php5/pecl-yaz/ChangeLog
index ae6f61f997c9..e66bdffb6445 100644
--- a/dev-php5/pecl-yaz/ChangeLog
+++ b/dev-php5/pecl-yaz/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/pecl-yaz
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-yaz/ChangeLog,v 1.25 2007/12/06 01:22:27 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-yaz/ChangeLog,v 1.26 2007/12/24 14:46:30 armin76 Exp $
+
+*pecl-yaz-1.0.13 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> +pecl-yaz-1.0.13.ebuild:
+ Version bump from the php-overlay
+
+ 18 Dec 2007; Jakub Moc <jakub@gentoo.org> +pecl-yaz-1.0.13.ebuild:
+ Version bump
06 Dec 2007; Markus Ullmann <jokey@gentoo.org> pecl-yaz-1.0.8.ebuild:
LICENSE fix from project overlay
diff --git a/dev-php5/pecl-yaz/files/digest-pecl-yaz-1.0.13 b/dev-php5/pecl-yaz/files/digest-pecl-yaz-1.0.13
new file mode 100644
index 000000000000..b816b590ef18
--- /dev/null
+++ b/dev-php5/pecl-yaz/files/digest-pecl-yaz-1.0.13
@@ -0,0 +1,3 @@
+MD5 ee2c198d0920a0849c97b8454ac2a71d yaz-1.0.13.tgz 16537
+RMD160 f3c106a52d8292f1c190842a210bfbcdedd8367b yaz-1.0.13.tgz 16537
+SHA256 e5c97d13d73ff821690c29b9365ac52eefa62f36dad1cbf74d18b1d08c2c1681 yaz-1.0.13.tgz 16537
diff --git a/dev-php5/pecl-yaz/pecl-yaz-1.0.13.ebuild b/dev-php5/pecl-yaz/pecl-yaz-1.0.13.ebuild
new file mode 100644
index 000000000000..b1ff2a3db851
--- /dev/null
+++ b/dev-php5/pecl-yaz/pecl-yaz-1.0.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-yaz/pecl-yaz-1.0.13.ebuild,v 1.1 2007/12/24 14:46:30 armin76 Exp $
+
+PHP_EXT_NAME="yaz"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="This extension implements a Z39.50 client for PHP using the YAZ toolkit."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/yaz-3.0.2"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+ my_conf="--with-yaz=/usr"
+ php-ext-pecl-r1_src_compile
+}
diff --git a/dev-php5/php-java-bridge/ChangeLog b/dev-php5/php-java-bridge/ChangeLog
index 447fd3167c87..1715f95cb094 100644
--- a/dev-php5/php-java-bridge/ChangeLog
+++ b/dev-php5/php-java-bridge/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-php5/php-java-bridge
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/php-java-bridge/ChangeLog,v 1.22 2007/11/25 16:10:41 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/php-java-bridge/ChangeLog,v 1.23 2007/12/24 14:47:41 armin76 Exp $
+
+*php-java-bridge-4.3.2 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org>
+ +php-java-bridge-4.3.2.ebuild:
+ Version bump from the php-overlay
+
+ 21 Dec 2007; Jakub Moc <jakub@gentoo.org>
+ +php-java-bridge-4.3.2.ebuild:
+ Version bump, add doc and examples use flags
25 Nov 2007; Brent Baude <ranger@gentoo.org> php-java-bridge-4.3.0.ebuild:
Marking php-java-bridge-4.3.0 ppc for bug 199339
diff --git a/dev-php5/php-java-bridge/files/digest-php-java-bridge-4.3.2 b/dev-php5/php-java-bridge/files/digest-php-java-bridge-4.3.2
new file mode 100644
index 000000000000..5b09ca900c3c
--- /dev/null
+++ b/dev-php5/php-java-bridge/files/digest-php-java-bridge-4.3.2
@@ -0,0 +1,3 @@
+MD5 fa568201c6d57f1c1ccea74f5cd47c96 php-java-bridge_4.3.2.tar.gz 14566673
+RMD160 b7e1ff307934cbc6643a83fbe997935bb1435f88 php-java-bridge_4.3.2.tar.gz 14566673
+SHA256 5d66390b4825dd65e211acfba3d02fa1fd2831d8318ebee04dd92e65b3f559fa php-java-bridge_4.3.2.tar.gz 14566673
diff --git a/dev-php5/php-java-bridge/php-java-bridge-4.3.2.ebuild b/dev-php5/php-java-bridge/php-java-bridge-4.3.2.ebuild
new file mode 100644
index 000000000000..743b2233b582
--- /dev/null
+++ b/dev-php5/php-java-bridge/php-java-bridge-4.3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/php-java-bridge/php-java-bridge-4.3.2.ebuild,v 1.1 2007/12/24 14:47:41 armin76 Exp $
+
+PHP_EXT_NAME="java"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-source-r1
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="The PHP/Java bridge is a PHP module wich connects the PHP object system with the Java or ECMA 335 object system."
+HOMEPAGE="http://php-java-bridge.sourceforge.net/"
+SRC_URI="mirror://sourceforge/php-java-bridge/${PN}_${PV}.tar.gz"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="doc examples"
+
+DEPEND=">=virtual/jdk-1.4.2"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use session
+}
+
+src_compile() {
+ my_conf="--disable-servlet --with-java=$(java-config --jdk-home)"
+ php-ext-source-r1_src_compile
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+
+ insinto "${EXT_DIR}"
+ doins modules/JavaBridge.jar
+ doins modules/RunJavaBridge
+ doins modules/java.so
+
+ dodoc-php CREDITS ChangeLog README README.GNU_JAVA PROTOCOL.TXT \
+ php_java_lib/{JPersistence,JSession,JspTag,java_helper,jikes_compiler}.php php_java_lib/README.txt
+
+ if use doc ; then
+ insinto /usr/share/doc/${CATEGORY}/${PF}
+ doins -r documentation/API
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${CATEGORY}/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index da8b41c989a5..a28629a7a5cb 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.9 2007/11/24 17:12:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.10 2007/12/24 14:49:25 armin76 Exp $
+
+*phpunit-3.2.5 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> +phpunit-3.2.5.ebuild:
+ Version bump from the php-overlay
+
+ 21 Dec 2007; Jakub Moc <jakub@gentoo.org> +phpunit-3.2.5.ebuild:
+ Version bump
*phpunit-3.2.0 (24 Nov 2007)
diff --git a/dev-php5/phpunit/files/digest-phpunit-3.2.5 b/dev-php5/phpunit/files/digest-phpunit-3.2.5
new file mode 100644
index 000000000000..16a0b49b02bc
--- /dev/null
+++ b/dev-php5/phpunit/files/digest-phpunit-3.2.5
@@ -0,0 +1,3 @@
+MD5 8ccc8012df0121be23015ae8b1defa3d PHPUnit-3.2.5.tgz 198096
+RMD160 0beda526d104825fd4a076ad45d881133a3099dd PHPUnit-3.2.5.tgz 198096
+SHA256 c7db69dc49da9643626752e642902a12350f861b27aa7aff7fdc06797cf8db49 PHPUnit-3.2.5.tgz 198096
diff --git a/dev-php5/phpunit/phpunit-3.2.5.ebuild b/dev-php5/phpunit/phpunit-3.2.5.ebuild
new file mode 100644
index 000000000000..ff411b69bd99
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.2.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.2.5.ebuild,v 1.1 2007/12/24 14:49:25 armin76 Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Unit Testing framework for PHP 5."
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="!dev-php4/phpunit"
+RDEPEND="${DEPEND}
+ !minimal? ( >=dev-php5/xdebug-2.0.0_rc2
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use pcre reflection spl xml tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+}
diff --git a/dev-php5/propel-generator/ChangeLog b/dev-php5/propel-generator/ChangeLog
index 5d743481856c..73e60b2a998f 100644
--- a/dev-php5/propel-generator/ChangeLog
+++ b/dev-php5/propel-generator/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-php5/propel-generator
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-generator/ChangeLog,v 1.8 2007/03/20 18:39:47 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-generator/ChangeLog,v 1.9 2007/12/24 14:51:03 armin76 Exp $
+
+*propel-generator-1.3.0_beta3 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org>
+ +propel-generator-1.3.0_beta3.ebuild:
+ Version bump from the php-overlay
+
+ 21 Dec 2007; Jakub Moc <jakub@gentoo.org>
+ +propel-generator-1.3.0_beta3.ebuild:
+ Version bump
*propel-generator-1.3.0_beta2 (20 Mar 2007)
diff --git a/dev-php5/propel-generator/files/digest-propel-generator-1.3.0_beta3 b/dev-php5/propel-generator/files/digest-propel-generator-1.3.0_beta3
new file mode 100644
index 000000000000..4cc0cc653ad2
--- /dev/null
+++ b/dev-php5/propel-generator/files/digest-propel-generator-1.3.0_beta3
@@ -0,0 +1,3 @@
+MD5 3ed6a45cdf4504df2a4ff8597f795005 propel_generator-1.3.0beta3.tgz 153283
+RMD160 ec37b6d5e4f8129dd7603c2d14d6a17c818d2f8f propel_generator-1.3.0beta3.tgz 153283
+SHA256 4dfab26e4c0e97c49924a1fb1a5cc8476dcb262dc9b2d04c0e696666c945710e propel_generator-1.3.0beta3.tgz 153283
diff --git a/dev-php5/propel-generator/propel-generator-1.3.0_beta3.ebuild b/dev-php5/propel-generator/propel-generator-1.3.0_beta3.ebuild
new file mode 100644
index 000000000000..6457d82c3fc9
--- /dev/null
+++ b/dev-php5/propel-generator/propel-generator-1.3.0_beta3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-generator/propel-generator-1.3.0_beta3.ebuild,v 1.1 2007/12/24 14:51:03 armin76 Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Object Persistence Layer for PHP 5 (Generator)."
+HOMEPAGE="http://propel.phpdb.org/trac/wiki/"
+SRC_URI="http://pear.phpdb.org/get/propel_generator-${PV/_/}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND=">=dev-lang/php-5.2.0"
+RDEPEND="${DEPEND}
+ >=dev-php5/phing-2.2.0"
+PDEPEND="!minimal? ( >=dev-php5/creole-1.1.0 )"
+
+S="${WORKDIR}/propel_generator-${PV/_/}"
+
+pkg_setup() {
+ # We need PDO and a few other things
+ require_php_with_use pdo reflection spl xml xsl
+}
diff --git a/dev-php5/propel-runtime/ChangeLog b/dev-php5/propel-runtime/ChangeLog
index cd84a70c43e8..d2d276301c1b 100644
--- a/dev-php5/propel-runtime/ChangeLog
+++ b/dev-php5/propel-runtime/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-php5/propel-runtime
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-runtime/ChangeLog,v 1.7 2007/03/20 18:36:50 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-runtime/ChangeLog,v 1.8 2007/12/24 14:52:00 armin76 Exp $
+
+*propel-runtime-1.3.0_beta3 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org>
+ +propel-runtime-1.3.0_beta3.ebuild:
+ Version bump from the php-overlay
+
+ 21 Dec 2007; Jakub Moc <jakub@gentoo.org>
+ +propel-runtime-1.3.0_beta3.ebuild:
+ Version bump
*propel-runtime-1.3.0_beta2 (20 Mar 2007)
diff --git a/dev-php5/propel-runtime/files/digest-propel-runtime-1.3.0_beta3 b/dev-php5/propel-runtime/files/digest-propel-runtime-1.3.0_beta3
new file mode 100644
index 000000000000..645338fb2112
--- /dev/null
+++ b/dev-php5/propel-runtime/files/digest-propel-runtime-1.3.0_beta3
@@ -0,0 +1,3 @@
+MD5 62b280d30f442dec1f6aa34f6327cf21 propel_runtime-1.3.0beta3.tgz 50159
+RMD160 530accc2def2aa86d6fc59acfbcbee32227f0316 propel_runtime-1.3.0beta3.tgz 50159
+SHA256 c45a8ad9a47bc2045c139cd7332f4c63b557307f57b4c52cee804ab6814a6656 propel_runtime-1.3.0beta3.tgz 50159
diff --git a/dev-php5/propel-runtime/propel-runtime-1.3.0_beta3.ebuild b/dev-php5/propel-runtime/propel-runtime-1.3.0_beta3.ebuild
new file mode 100644
index 000000000000..66415a4f388c
--- /dev/null
+++ b/dev-php5/propel-runtime/propel-runtime-1.3.0_beta3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-runtime/propel-runtime-1.3.0_beta3.ebuild,v 1.1 2007/12/24 14:52:00 armin76 Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Object Persistence Layer for PHP 5 (Runtime)."
+HOMEPAGE="http://propel.phpdb.org/trac/wiki/"
+SRC_URI="http://pear.phpdb.org/get/propel_runtime-${PV/_/}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/php-5.2.0"
+RDEPEND="${DEPEND}
+ >=dev-php/PEAR-Log-1.8.7-r1"
+
+S="${WORKDIR}/propel_runtime-${PV/_/}"
+
+pkg_setup() {
+ # We need PDO and a few other things
+ require_php_with_use pdo reflection spl xml xsl
+}
diff --git a/dev-php5/propel/ChangeLog b/dev-php5/propel/ChangeLog
index 34ed0b805814..65b0e23cd1b1 100644
--- a/dev-php5/propel/ChangeLog
+++ b/dev-php5/propel/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/propel
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel/ChangeLog,v 1.7 2007/03/20 18:44:46 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel/ChangeLog,v 1.8 2007/12/24 14:52:26 armin76 Exp $
+
+*propel-1.3.0_beta3 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> +propel-1.3.0_beta3.ebuild:
+ Version bump from the php-overlay
+
+ 21 Dec 2007; Jakub Moc <jakub@gentoo.org> +propel-1.3.0_beta3.ebuild:
+ Version bump
*propel-1.3.0_beta2 (20 Mar 2007)
diff --git a/dev-php5/propel/files/digest-propel-1.3.0_beta3 b/dev-php5/propel/files/digest-propel-1.3.0_beta3
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-php5/propel/files/digest-propel-1.3.0_beta3
diff --git a/dev-php5/propel/propel-1.3.0_beta3.ebuild b/dev-php5/propel/propel-1.3.0_beta3.ebuild
new file mode 100644
index 000000000000..2fff73f0137e
--- /dev/null
+++ b/dev-php5/propel/propel-1.3.0_beta3.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel/propel-1.3.0_beta3.ebuild,v 1.1 2007/12/24 14:52:26 armin76 Exp $
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Object Persistence Layer for PHP 5."
+HOMEPAGE="http://propel.phpdb.org/trac/wiki/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="~dev-php5/propel-generator-${PV}
+ ~dev-php5/propel-runtime-${PV}"
diff --git a/dev-php5/symfony/ChangeLog b/dev-php5/symfony/ChangeLog
index a6f1a498f926..4622305b5bab 100644
--- a/dev-php5/symfony/ChangeLog
+++ b/dev-php5/symfony/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/symfony
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/symfony/ChangeLog,v 1.4 2007/12/06 01:24:28 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/symfony/ChangeLog,v 1.5 2007/12/24 14:53:14 armin76 Exp $
+
+*symfony-1.0.10 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> +symfony-1.0.10.ebuild:
+ Version bump from the php-overlay
+
+ 21 Dec 2007; Jakub Moc <jakub@gentoo.org> +symfony-1.0.10.ebuild:
+ Version bump
*symfony-1.0.9 (06 Dec 2007)
diff --git a/dev-php5/symfony/files/digest-symfony-1.0.10 b/dev-php5/symfony/files/digest-symfony-1.0.10
new file mode 100644
index 000000000000..92cfcaf9abd5
--- /dev/null
+++ b/dev-php5/symfony/files/digest-symfony-1.0.10
@@ -0,0 +1,3 @@
+MD5 5f1c9bbb510665a11784c79ce8271cc1 symfony-1.0.10.tgz 1912670
+RMD160 7e3860067a324a723d9339a54719ccb7f8569c83 symfony-1.0.10.tgz 1912670
+SHA256 7e1c7b868339c546ad6d5ca15af3af1a21a352b8f88887f79b1cca152349f641 symfony-1.0.10.tgz 1912670
diff --git a/dev-php5/symfony/symfony-1.0.10.ebuild b/dev-php5/symfony/symfony-1.0.10.ebuild
new file mode 100644
index 000000000000..f6d38b4cb9e7
--- /dev/null
+++ b/dev-php5/symfony/symfony-1.0.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/symfony/symfony-1.0.10.ebuild,v 1.1 2007/12/24 14:53:14 armin76 Exp $
+
+inherit php-pear-lib-r1 depend.php
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Open-source PHP5 professional web framework."
+HOMEPAGE="http://www.symfony-project.com/"
+SRC_URI="http://pear.symfony-project.com/get/${P}.tgz"
+LICENSE="MIT LGPL-2.1 BSD BSD-2 FDL-1.2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+pkg_setup() {
+ # Symfony needs some features in PHP5 in order to work
+ require_php_with_use cli ctype reflection spl simplexml xml pcre session
+}