summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-01-06 17:43:54 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-01-06 17:43:54 +0000
commit8eae23c6a1a58c10be73d61add3a8b7c33dfd623 (patch)
tree072bab9998a73efae5d5222f942c675439e9bece /dev-php5/pecl-memcache
parentMoved to dev-php4/PEAR-XML_CSSML. (diff)
downloadhistorical-8eae23c6a1a58c10be73d61add3a8b7c33dfd623.tar.gz
historical-8eae23c6a1a58c10be73d61add3a8b7c33dfd623.tar.bz2
historical-8eae23c6a1a58c10be73d61add3a8b7c33dfd623.zip
Fix bug #117990.
Package-Manager: portage-2.0.53
Diffstat (limited to 'dev-php5/pecl-memcache')
-rw-r--r--dev-php5/pecl-memcache/ChangeLog6
-rw-r--r--dev-php5/pecl-memcache/Manifest15
-rw-r--r--dev-php5/pecl-memcache/files/config-zlib-det-fix.patch103
-rw-r--r--dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild14
4 files changed, 123 insertions, 15 deletions
diff --git a/dev-php5/pecl-memcache/ChangeLog b/dev-php5/pecl-memcache/ChangeLog
index 40d2a6d9df0d..6042eecfe126 100644
--- a/dev-php5/pecl-memcache/ChangeLog
+++ b/dev-php5/pecl-memcache/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php5/pecl-memcache
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.5 2006/01/05 17:07:59 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.6 2006/01/06 17:43:54 chtekk Exp $
+
+ 06 Jan 2006; Luca Longinotti <chtekk@gentoo.org>
+ +files/config-zlib-det-fix.patch, pecl-memcache-2.0.0.ebuild:
+ Fix bug #117990.
*pecl-memcache-2.0.0 (05 Jan 2006)
diff --git a/dev-php5/pecl-memcache/Manifest b/dev-php5/pecl-memcache/Manifest
index 96dc882fe64a..265cc1cce6a7 100644
--- a/dev-php5/pecl-memcache/Manifest
+++ b/dev-php5/pecl-memcache/Manifest
@@ -1,14 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 314c7bf2baddc62f726c683d28852f8d ChangeLog 795
+MD5 8cade83fdf7a20327ee448f1e3148329 ChangeLog 927
+MD5 7a4ae6237c651bc458cc5dd85224b5e3 files/config-zlib-det-fix.patch 3403
MD5 2b340edcc01d9e1afddcf52d7cc5cb32 files/digest-pecl-memcache-2.0.0 62
MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
-MD5 7c7d3625aecbb987c923918d590408fd pecl-memcache-2.0.0.ebuild 601
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDvVMKaGfFFLhbXWkRAuZDAKCZC1fW2mnzJz64z6QwenMoDnlqggCgn8uh
-OeQhYpXGNIrrbTmcey8YCxs=
-=9vyF
------END PGP SIGNATURE-----
+MD5 4f97559d138de60069eed9512cb6b4ab pecl-memcache-2.0.0.ebuild 733
diff --git a/dev-php5/pecl-memcache/files/config-zlib-det-fix.patch b/dev-php5/pecl-memcache/files/config-zlib-det-fix.patch
new file mode 100644
index 000000000000..5ce9eff569b6
--- /dev/null
+++ b/dev-php5/pecl-memcache/files/config-zlib-det-fix.patch
@@ -0,0 +1,103 @@
+--- config.m4 2005-11-27 12:05:10.000000000 +0100
++++ config.m4 2006-01-06 18:30:46.000000000 +0100
+@@ -1,49 +1,51 @@
+-dnl
+-dnl $Id: config.m4,v 1.4 2005/11/26 17:53:18 tony2001 Exp $
+-dnl
+-
+-PHP_ARG_ENABLE(memcache, whether to enable memcache support,
+-[ --enable-memcache Enable memcache support])
+-
+-if test -z "$PHP_ZLIB_DIR"; then
+-PHP_ARG_WITH(zlib-dir, for the location of libz,
+-[ --with-zlib-dir[=DIR] memcache: Set the path to libz install prefix.], no, no)
+-fi
+-
+-if test "$PHP_MEMCACHE" != "no"; then
+-
+- if test "$PHP_ZLIB_DIR" != "no"; then
+- if test -f $PHP_ZLIB_DIR/include/zlib/zlib.h; then
+- PHP_ZLIB_DIR=$PHP_ZLIB_DIR
+- PHP_ZLIB_INCDIR=$PHP_ZLIB_DIR/include/zlib
+- elif test -f $PHP_ZLIB_DIR/include/zlib.h; then
+- PHP_ZLIB_DIR=$PHP_ZLIB_DIR
+- PHP_ZLIB_INCDIR=$PHP_ZLIB_DIR/include
+- fi
+- else
+- for i in /usr/local /usr; do
+- if test -f $i/include/zlib/zlib.h; then
+- PHP_ZLIB_DIR=$i
+- PHP_ZLIB_INCDIR=$i/include/zlib
+- elif test -f $i/include/zlib.h; then
+- PHP_ZLIB_DIR=$i
+- PHP_ZLIB_INCDIR=$i/include
+- fi
+- done
+- fi
+-
+- dnl # zlib
+- AC_MSG_CHECKING([for the location of zlib])
+- if test "$PHP_ZLIB_DIR" = "no"; then
+- AC_MSG_ERROR([memcache support requires ZLIB. Use --with-zlib-dir=<DIR>])
+- else
+- AC_MSG_RESULT([$PHP_ZLIB_DIR])
+- PHP_ADD_LIBRARY_WITH_PATH(z, $PHP_ZLIB_DIR/lib, MEMCACHE_SHARED_LIBADD)
+- PHP_ADD_INCLUDE($PHP_ZLIB_INCDIR)
+- fi
+-
+- AC_DEFINE(HAVE_MEMCACHE,1,[Whether you want memcache support])
+- PHP_NEW_EXTENSION(memcache, memcache.c, $ext_shared)
+-fi
+-
+-
++dnl
++dnl $Id: config.m4,v 1.5 2005/12/29 15:27:57 tony2001 Exp $
++dnl
++
++PHP_ARG_ENABLE(memcache, whether to enable memcache support,
++[ --enable-memcache Enable memcache support])
++
++if test -z "$PHP_ZLIB_DIR"; then
++PHP_ARG_WITH(zlib-dir, for the location of libz,
++[ --with-zlib-dir[=DIR] memcache: Set the path to libz install prefix.], no, no)
++fi
++
++if test "$PHP_MEMCACHE" != "no"; then
++
++ if test "$PHP_ZLIB_DIR" != "no" && test "$PHP_ZLIB_DIR" != "yes"; then
++ if test -f "$PHP_ZLIB_DIR/include/zlib/zlib.h"; then
++ PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
++ PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include/zlib"
++ elif test -f "$PHP_ZLIB_DIR/include/zlib.h"; then
++ PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
++ PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include"
++ else
++ AC_MSG_ERROR([Can't find zlib headers under "$PHP_ZLIB_DIR"])
++ fi
++ else
++ for i in /usr/local /usr; do
++ if test -f "$i/include/zlib/zlib.h"; then
++ PHP_ZLIB_DIR="$i"
++ PHP_ZLIB_INCDIR="$i/include/zlib"
++ elif test -f "$i/include/zlib.h"; then
++ PHP_ZLIB_DIR="$i"
++ PHP_ZLIB_INCDIR="$i/include"
++ fi
++ done
++ fi
++
++ dnl # zlib
++ AC_MSG_CHECKING([for the location of zlib])
++ if test "$PHP_ZLIB_DIR" = "no"; then
++ AC_MSG_ERROR([memcache support requires ZLIB. Use --with-zlib-dir=<DIR> to specify prefix where ZLIB include and library are located])
++ else
++ AC_MSG_RESULT([$PHP_ZLIB_DIR])
++ PHP_ADD_LIBRARY_WITH_PATH(z, $PHP_ZLIB_DIR/lib, MEMCACHE_SHARED_LIBADD)
++ PHP_ADD_INCLUDE($PHP_ZLIB_INCDIR)
++ fi
++
++ AC_DEFINE(HAVE_MEMCACHE,1,[Whether you want memcache support])
++ PHP_NEW_EXTENSION(memcache, memcache.c, $ext_shared)
++fi
++
++
diff --git a/dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild b/dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild
index 5d2f056c42a2..bf578bbc8856 100644
--- a/dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild
+++ b/dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild,v 1.1 2006/01/05 17:07:59 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/pecl-memcache-2.0.0.ebuild,v 1.2 2006/01/06 17:43:54 chtekk Exp $
PHP_EXT_NAME="memcache"
PHP_EXT_INI="yes"
@@ -9,7 +9,7 @@ PHP_EXT_ZENDEXT="no"
inherit php-ext-pecl-r1
KEYWORDS="~ppc ~ppc64 ~sparc ~x86"
-DESCRIPTION="PHP extension to use memcached."
+DESCRIPTION="PHP extension for using memcached."
LICENSE="PHP"
SLOT="0"
IUSE=""
@@ -19,8 +19,18 @@ DEPEND="${DEPEND}
need_php_by_category
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # change configure to fix bug #117990
+ epatch "${FILESDIR}/config-zlib-det-fix.patch"
+}
+
src_compile() {
has_php
+
my_conf="--enable-memcache --with-zlib-dir=/usr"
php-ext-pecl-r1_src_compile
}