summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-05-01 19:30:48 +0000
committerMatti Bickel <mabi@gentoo.org>2010-05-01 19:30:48 +0000
commit784f74ee41548429f4054507a0cae4369f68252f (patch)
tree727d069e3fdaf3939be6d5ae452f116819f40cd8 /dev-php/xdebug-client/xdebug-client-2.1.0_rc1.ebuild
parentcleanup (diff)
downloadhistorical-784f74ee41548429f4054507a0cae4369f68252f.tar.gz
historical-784f74ee41548429f4054507a0cae4369f68252f.tar.bz2
historical-784f74ee41548429f4054507a0cae4369f68252f.zip
bump
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'dev-php/xdebug-client/xdebug-client-2.1.0_rc1.ebuild')
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.1.0_rc1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/xdebug-client/xdebug-client-2.1.0_rc1.ebuild b/dev-php/xdebug-client/xdebug-client-2.1.0_rc1.ebuild
new file mode 100644
index 000000000000..6aafe6d0e3d1
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.1.0_rc1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.1.0_rc1.ebuild,v 1.1 2010/05/01 19:30:48 mabi Exp $
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_with libedit) --disable-dependency-tracking
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}