summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2011-12-14 22:57:20 +0000
committerMatti Bickel <mabi@gentoo.org>2011-12-14 22:57:20 +0000
commit37185de2eff1409dc7abe39ac6aa5087fcd20136 (patch)
treed0c227d9d72631cf8cf14a810d13ae41a6abaef1 /dev-php/pecl-imagick/pecl-imagick-3.0.1-r1.ebuild
parentMerging categories dev-php5 and dev-php (bug #324665) (diff)
downloadhistorical-37185de2eff1409dc7abe39ac6aa5087fcd20136.tar.gz
historical-37185de2eff1409dc7abe39ac6aa5087fcd20136.tar.bz2
historical-37185de2eff1409dc7abe39ac6aa5087fcd20136.zip
Moving package from dev-php5 to dev-php category (bug #324665)
Package-Manager: portage-2.2.0_alpha79/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'dev-php/pecl-imagick/pecl-imagick-3.0.1-r1.ebuild')
-rw-r--r--dev-php/pecl-imagick/pecl-imagick-3.0.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/pecl-imagick/pecl-imagick-3.0.1-r1.ebuild b/dev-php/pecl-imagick/pecl-imagick-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..1cb761dbaf9b
--- /dev/null
+++ b/dev-php/pecl-imagick/pecl-imagick-3.0.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-imagick/pecl-imagick-3.0.1-r1.ebuild,v 1.1 2011/12/14 22:39:57 mabi Exp $
+
+EAPI=3
+
+PHP_EXT_NAME="imagick"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="TODO"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 x86"
+
+DESCRIPTION="PHP wrapper for the ImageMagick library."
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="examples"
+
+DEPEND=">=media-gfx/imagemagick-6.2.4"
+RDEPEND="${DEPEND}"
+
+MY_PV="${PV/_/}"
+PECL_PKG_V="${PECL_PKG}-${MY_PV}"
+FILENAME="${PECL_PKG_V}.tgz"
+SRC_URI="http://pecl.php.net/get/${FILENAME}"
+S="${WORKDIR}/${PECL_PKG_V}"
+
+my_conf="--with-imagick=/usr"