summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-02-23 10:07:46 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-02-23 10:07:46 +0000
commit4733e90a95b7bf71c9fdbe771d313375a691ee4a (patch)
tree1e9fbca79734aecac65cc3b10418050b1ac9025e /dev-perl
parentebuild.minorsyn stuff. (diff)
downloadhistorical-4733e90a95b7bf71c9fdbe771d313375a691ee4a.tar.gz
historical-4733e90a95b7bf71c9fdbe771d313375a691ee4a.tar.bz2
historical-4733e90a95b7bf71c9fdbe771d313375a691ee4a.zip
Version bump via perl-bump experimental tool.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/DateTime-Format-Strptime/ChangeLog10
-rw-r--r--dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.0900.ebuild22
-rw-r--r--dev-perl/JSON-XS/ChangeLog8
-rw-r--r--dev-perl/JSON-XS/JSON-XS-2.2.3.2.ebuild23
-rw-r--r--dev-perl/Sphinx-Search/ChangeLog10
-rw-r--r--dev-perl/Sphinx-Search/Sphinx-Search-0.14.ebuild23
-rw-r--r--dev-perl/math-pari/ChangeLog10
-rw-r--r--dev-perl/math-pari/math-pari-2.010801.ebuild40
8 files changed, 139 insertions, 7 deletions
diff --git a/dev-perl/DateTime-Format-Strptime/ChangeLog b/dev-perl/DateTime-Format-Strptime/ChangeLog
index f2476a1b0269..24370fe3ad90 100644
--- a/dev-perl/DateTime-Format-Strptime/ChangeLog
+++ b/dev-perl/DateTime-Format-Strptime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/DateTime-Format-Strptime
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DateTime-Format-Strptime/ChangeLog,v 1.1 2008/12/09 08:53:37 robbat2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DateTime-Format-Strptime/ChangeLog,v 1.2 2009/02/23 10:02:47 robbat2 Exp $
+
+*DateTime-Format-Strptime-1.0900 (23 Feb 2009)
+
+ 23 Feb 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +DateTime-Format-Strptime-1.0900.ebuild:
+ Version bump via perl-bump experimental tool.
*DateTime-Format-Strptime-1.0800 (09 Dec 2008)
diff --git a/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.0900.ebuild b/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.0900.ebuild
new file mode 100644
index 000000000000..4de15afc7525
--- /dev/null
+++ b/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.0900.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.0900.ebuild,v 1.1 2009/02/23 10:02:47 robbat2 Exp $
+
+MODULE_AUTHOR="RICKM"
+MODULE_A="${P}.tgz"
+
+inherit perl-module
+
+DESCRIPTION="Parse and Format DateTimes using Strptime"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-perl/DateTime
+ dev-perl/DateTime-Locale
+ dev-perl/DateTime-TimeZone
+ >=dev-perl/Params-Validate-0.91
+ dev-lang/perl"
diff --git a/dev-perl/JSON-XS/ChangeLog b/dev-perl/JSON-XS/ChangeLog
index e7267af4bbce..a40be37afb8d 100644
--- a/dev-perl/JSON-XS/ChangeLog
+++ b/dev-perl/JSON-XS/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/JSON-XS
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/JSON-XS/ChangeLog,v 1.14 2009/02/20 06:10:16 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/JSON-XS/ChangeLog,v 1.15 2009/02/23 10:03:43 robbat2 Exp $
+
+*JSON-XS-2.2.3.2 (23 Feb 2009)
+
+ 23 Feb 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +JSON-XS-2.2.3.2.ebuild:
+ Version bump via perl-bump experimental tool.
*JSON-XS-2.2.3.1.1 (20 Feb 2009)
diff --git a/dev-perl/JSON-XS/JSON-XS-2.2.3.2.ebuild b/dev-perl/JSON-XS/JSON-XS-2.2.3.2.ebuild
new file mode 100644
index 000000000000..19d6c16b695a
--- /dev/null
+++ b/dev-perl/JSON-XS/JSON-XS-2.2.3.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/JSON-XS/JSON-XS-2.2.3.2.ebuild,v 1.1 2009/02/23 10:03:43 robbat2 Exp $
+
+inherit versionator
+MODULE_AUTHOR=MLEHMANN
+MY_P=${PN}-"$(get_major_version).$(delete_all_version_separators $(get_after_major_version))"
+inherit perl-module
+
+DESCRIPTION="JSON::XS - JSON serialising/deserialising, done correctly and fast"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}
+ test? ( virtual/perl-Test-Harness )"
+
+S=${WORKDIR}/${MY_P}
+
+SRC_TEST="do"
diff --git a/dev-perl/Sphinx-Search/ChangeLog b/dev-perl/Sphinx-Search/ChangeLog
index 7ae52861d59b..66ae8995ea84 100644
--- a/dev-perl/Sphinx-Search/ChangeLog
+++ b/dev-perl/Sphinx-Search/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Sphinx-Search
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Sphinx-Search/ChangeLog,v 1.3 2008/09/30 06:30:37 robbat2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Sphinx-Search/ChangeLog,v 1.4 2009/02/23 10:07:46 robbat2 Exp $
+
+*Sphinx-Search-0.14 (23 Feb 2009)
+
+ 23 Feb 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +Sphinx-Search-0.14.ebuild:
+ Version bump via perl-bump experimental tool.
30 Sep 2008; Robin H. Johnson <robbat2@gentoo.org>
Sphinx-Search-0.11.ebuild, Sphinx-Search-0.12.ebuild:
diff --git a/dev-perl/Sphinx-Search/Sphinx-Search-0.14.ebuild b/dev-perl/Sphinx-Search/Sphinx-Search-0.14.ebuild
new file mode 100644
index 000000000000..87634cf208f3
--- /dev/null
+++ b/dev-perl/Sphinx-Search/Sphinx-Search-0.14.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Sphinx-Search/Sphinx-Search-0.14.ebuild,v 1.1 2009/02/23 10:07:46 robbat2 Exp $
+
+MODULE_AUTHOR="JJSCHUTZ"
+inherit perl-module
+
+DESCRIPTION="Perl API client for Sphinx search engine"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="dev-perl/File-SearchPath
+ dev-perl/Path-Class
+ dev-perl/DBI
+ dev-lang/perl"
+
+pkg_postinst() {
+ ewarn "You must connect to a Sphinx searchd of 0.9.8_rc1 or newer"
+}
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index aeab698a5279..9ec979a14ab8 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/math-pari
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.41 2008/12/21 01:48:05 robbat2 Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.42 2009/02/23 10:05:58 robbat2 Exp $
+
+*math-pari-2.010801 (23 Feb 2009)
+
+ 23 Feb 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +math-pari-2.010801.ebuild:
+ Version bump via perl-bump experimental tool.
21 Dec 2008; Robin H. Johnson <robbat2@gentoo.org>
math-pari-2.010800.ebuild:
diff --git a/dev-perl/math-pari/math-pari-2.010801.ebuild b/dev-perl/math-pari/math-pari-2.010801.ebuild
new file mode 100644
index 000000000000..12330f5fd3e8
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.010801.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010801.ebuild,v 1.1 2009/02/23 10:05:58 robbat2 Exp $
+
+inherit perl-module eutils
+
+MY_P="Math-Pari-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl interface to PARI"
+HOMEPAGE="http://www.cpan.org/authors/id/I/IL/ILYAZ/modules/${MY_P}.readme"
+SRC_URI="mirror://cpan/authors/id/I/IL/ILYAZ/modules/${MY_P}.tar.gz
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-2.1.7.tgz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+# Math::Pari does NOT work with 2.3. The Makefile.PL gives warnings, and if you
+# run the tests, you get failures.
+DEPEND="~sci-mathematics/pari-2.1.7
+ !=sci-mathematics/pari-2.3*
+ dev-lang/perl"
+
+src_compile() {
+ # Unfortunately the assembly routines math-pari has for SPARC do not appear
+ # to be working at current. Perl cannot test math-pari or anything that
+ # pulls in the math-pari module as DynaLoader cannot load the resulting
+ # .so files math-pari generates. As such, we have to use the generic
+ # non-machine specific assembly methods here.
+ use sparc && myconf="${myconf} machine=none"
+
+ perl-module_src_compile
+}