summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-11-11 07:43:32 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-11-11 07:43:32 +0000
commit3ccb261f31045b2b01d0961fa709238c9867d72d (patch)
tree62f518bb4dbfe42c2fc6f61a7f0b9409edee70cd /dev-perl/math-pari/math-pari-2.01080601.ebuild
parentBug #292658: version bump. (diff)
downloadhistorical-3ccb261f31045b2b01d0961fa709238c9867d72d.tar.gz
historical-3ccb261f31045b2b01d0961fa709238c9867d72d.tar.bz2
historical-3ccb261f31045b2b01d0961fa709238c9867d72d.zip
Version bump, now with working src_test again.
Package-Manager: portage-2.2_rc49/cvs/Linux x86_64
Diffstat (limited to 'dev-perl/math-pari/math-pari-2.01080601.ebuild')
-rw-r--r--dev-perl/math-pari/math-pari-2.01080601.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-perl/math-pari/math-pari-2.01080601.ebuild b/dev-perl/math-pari/math-pari-2.01080601.ebuild
new file mode 100644
index 000000000000..ab0ef6972368
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.01080601.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.01080601.ebuild,v 1.1 2009/11/11 07:43:32 robbat2 Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=ILYAZ
+MODULE_SECTION=modules
+MY_PN=Math-Pari
+MY_P=${MY_PN}-${PV}
+inherit perl-module
+
+PARI_VER=2.3.4
+
+DESCRIPTION="Perl interface to PARI"
+SRC_URI="${SRC_URI}
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-${PARI_VER}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+RDEPEND="~sci-mathematics/pari-${PARI_VER}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+S_PARI=${WORKDIR}/pari-${PARI_VER}
+SRC_TEST=do
+
+src_prepare() {
+ # On 64-bit hardware, these files are needed in both the 64/ and 32/
+ # directories for the testsuite to pass.
+ cd "${S_PARI}"/src/test/
+ for t in analyz compat ellglobalred elliptic galois graph intnum kernel \
+ linear nfields number objets ploth polyser program qfbsolve rfrac \
+ round4 stark sumiter trans ; do
+ i="in/${t}"
+ o32="32/${t}"
+ o64="64/${t}"
+ [ -f "$i" -a ! -f "$o32" ] && cp -al "$i" "$o32"
+ [ -f "$i" -a ! -f "$o64" ] && cp -al "$i" "$o64"
+ done
+ perl-module_src_prepare
+}
+
+src_configure() {
+ # Unfortunately the assembly routines math-pari has for SPARC do not appear
+ # to be working at current. Perl cannot test math-pari or anything that
+ # pulls in the math-pari module as DynaLoader cannot load the resulting
+ # .so files math-pari generates. As such, we have to use the generic
+ # non-machine specific assembly methods here.
+ use sparc && myconf="${myconf} machine=none"
+
+ perl-module_src_configure
+}