summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-05-13 03:23:12 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-05-13 03:23:12 +0000
commit977cdff835a65b51956da7a40ce0eaef8ae3901c (patch)
tree0a7467c6cd35dad3f2c878f3ea5ed9d000bb1beb /dev-perl/PerlQt
parentVersion bump (diff)
downloadhistorical-977cdff835a65b51956da7a40ce0eaef8ae3901c.tar.gz
historical-977cdff835a65b51956da7a40ce0eaef8ae3901c.tar.bz2
historical-977cdff835a65b51956da7a40ce0eaef8ae3901c.zip
Initial import - a perl wrapper for Qt libraries
Diffstat (limited to 'dev-perl/PerlQt')
-rw-r--r--dev-perl/PerlQt/ChangeLog9
-rw-r--r--dev-perl/PerlQt/PerlQt-3.006.ebuild59
-rw-r--r--dev-perl/PerlQt/files/digest-PerlQt-3.0061
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-perl/PerlQt/ChangeLog b/dev-perl/PerlQt/ChangeLog
new file mode 100644
index 000000000000..4cd101e0104b
--- /dev/null
+++ b/dev-perl/PerlQt/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-perl/PerlQt
+# Copyright 2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PerlQt/ChangeLog,v 1.1 2003/05/13 03:23:12 caleb Exp $
+
+*PerlQt-3.006 (May 12 2003)
+
+ 12 May 2003; Caleb Tennis <caleb@gentoo.org> PerlQt-3.006.ebuild:
+ Initial import (thanks to Christian Plessl). Fixed bug #16431.
+
diff --git a/dev-perl/PerlQt/PerlQt-3.006.ebuild b/dev-perl/PerlQt/PerlQt-3.006.ebuild
new file mode 100644
index 000000000000..a4baf585095e
--- /dev/null
+++ b/dev-perl/PerlQt/PerlQt-3.006.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PerlQt/PerlQt-3.006.ebuild,v 1.1 2003/05/13 03:23:12 caleb Exp $
+
+inherit kde-base perl-module
+
+#install pqtsh to this directory
+myinst="${myinst} INSTBINDIR=${D}/usr/bin"
+myconf="${myconf} --prefix=${D}/usr"
+mydoc="ChangeLog README TODO INSTALL COPYING AUTHORS"
+
+# may also works with kde 3.0, but not tested
+need-kde 3.1
+
+DESCRIPTION="Perl bindings for the Qt 3.x toolkit"
+HOMEPAGE="http://perlqt.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/perlqt/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+
+#if kdebindings is installed compilation is really fast!
+# because libsmoke comes with kdebindings-3.1
+
+DEPEND=" >=x11-libs/qt-3.0.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/PerlQt
+ cp Makefile.PL.in Makefile.PL.in.orig
+ perl -pi -e "s#WriteMakefile\(#WriteMakefile\(\n'PREFIX' => '${D}/usr',#" Makefile.PL.in
+ cd ${S}
+ perl-module_src_prep
+}
+
+
+
+src_install() {
+
+ perl-module_src_install
+
+ mkdir -p ${D}/usr/share/doc/${P}/tutorials
+ cp -r ${S}/PerlQt/tutorials/* ${D}/usr/share/doc/${P}/tutorials
+
+ for file in `find ${D}/usr/share/doc/${P}/tutorials/*/*.pl`;do
+ perl -pi -e "s/use blib;/#use blib;/" ${file}
+ chmod +x ${file}
+ done
+
+ mkdir -p ${D}/usr/share/doc/${P}/examples
+ cp -r ${S}/PerlQt/examples/* ${D}/usr/share/doc/${P}/examples
+ for file in `find ${D}/usr/share/doc/${P}/examples/*/*.pl`;do
+ chmod +x ${file}
+ done
+}
+
+
diff --git a/dev-perl/PerlQt/files/digest-PerlQt-3.006 b/dev-perl/PerlQt/files/digest-PerlQt-3.006
new file mode 100644
index 000000000000..ffe94f29728e
--- /dev/null
+++ b/dev-perl/PerlQt/files/digest-PerlQt-3.006
@@ -0,0 +1 @@
+MD5 4fe064c45364b024d62c3aadfbc919b5 PerlQt-3.006.tar.gz 839542