summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-10-16 12:51:20 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-10-16 12:51:20 +0000
commite80b3bc3ed61a721b93ef2c612ed81d8eb9ebc4d (patch)
tree64650b3b7f82eb5fde727e8b3b06be564c9b8a06 /dev-perl/PerlQt/PerlQt-3.008.ebuild
parentNew version, works good for me. (diff)
downloadhistorical-e80b3bc3ed61a721b93ef2c612ed81d8eb9ebc4d.tar.gz
historical-e80b3bc3ed61a721b93ef2c612ed81d8eb9ebc4d.tar.bz2
historical-e80b3bc3ed61a721b93ef2c612ed81d8eb9ebc4d.zip
New version, works good for me.
Diffstat (limited to 'dev-perl/PerlQt/PerlQt-3.008.ebuild')
-rw-r--r--dev-perl/PerlQt/PerlQt-3.008.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-perl/PerlQt/PerlQt-3.008.ebuild b/dev-perl/PerlQt/PerlQt-3.008.ebuild
new file mode 100644
index 000000000000..a0e710b1c59f
--- /dev/null
+++ b/dev-perl/PerlQt/PerlQt-3.008.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PerlQt/PerlQt-3.008.ebuild,v 1.1 2003/10/16 12:51:05 caleb Exp $
+
+inherit perl-module
+
+#install pqtsh to this directory
+myinst="${myinst} INSTBINDIR=${D}/usr/bin"
+myconf="${myconf} --prefix=${D}/usr"
+mydoc="ChangeLog README TODO INSTALL COPYING AUTHORS"
+
+DESCRIPTION="Perl bindings for the Qt 3.x toolkit"
+HOMEPAGE="http://perlqt.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/perlqt/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+
+#if kdebindings is installed compilation is really fast!
+# because libsmoke comes with kdebindings-3.1
+
+newdepend ">=x11-libs/qt-3.0.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/PerlQt
+ cp Makefile.PL.in Makefile.PL.in.orig
+ perl -pi -e "s#WriteMakefile\(#WriteMakefile\(\n'PREFIX' => '${D}/usr',#" Makefile.PL.in
+ cd ${S}
+ perl-module_src_prep
+}
+
+src_install() {
+
+ perl-module_src_install
+
+ mkdir -p ${D}/usr/share/doc/${P}/tutorials
+ cp -r ${S}/PerlQt/tutorials/* ${D}/usr/share/doc/${P}/tutorials
+
+ for file in `find ${D}/usr/share/doc/${P}/tutorials/*/*.pl`;do
+ perl -pi -e "s/use blib;/#use blib;/" ${file}
+ chmod +x ${file}
+ done
+
+ mkdir -p ${D}/usr/share/doc/${P}/examples
+ cp -r ${S}/PerlQt/examples/* ${D}/usr/share/doc/${P}/examples
+ for file in `find ${D}/usr/share/doc/${P}/examples/*/*.pl`;do
+ chmod +x ${file}
+ done
+}
+
+