summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2015-05-02 18:04:45 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2015-05-02 18:04:45 +0000
commit194be006f762ee9884f3b2daa4562fdb75f5df1c (patch)
tree3d48fce0b435113f4971f2d5d6f0501d4909f67d /dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0.ebuild
parentMention upstream patch in comment, thanks to Jake Petroules <jake.petroules@p... (diff)
downloadhistorical-194be006f762ee9884f3b2daa4562fdb75f5df1c.tar.gz
historical-194be006f762ee9884f3b2daa4562fdb75f5df1c.tar.bz2
historical-194be006f762ee9884f3b2daa4562fdb75f5df1c.zip
Version bump
Package-Manager: portage-2.2.18/cvs/Linux x86_64 Manifest-Sign-Key: 0x84AD142F
Diffstat (limited to 'dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0.ebuild')
-rw-r--r--dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0.ebuild b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0.ebuild
new file mode 100644
index 000000000000..5c8ed842a2ca
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0.ebuild,v 1.1 2015/05/02 18:04:29 dilfridge Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=NANIS
+MODULE_VERSION=0.72
+inherit perl-module
+
+DESCRIPTION="OpenSSL support for LWP"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/openssl-0.9.7c:0
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=virtual/perl-ExtUtils-CBuilder-0.280.205
+ virtual/perl-Getopt-Long
+ >=dev-perl/Path-Class-0.260.0
+ test? (
+ >=virtual/perl-Test-Simple-0.190.0
+ >=dev-perl/Try-Tiny-0.190.0
+ )
+"
+# PDEPEND: circular dependencies bug #144761
+PDEPEND="
+ dev-perl/libwww-perl
+ >=dev-perl/LWP-Protocol-https-6.20.0
+"
+
+export OPTIMIZE="${CFLAGS}"
+#myconf="--lib=${EPREFIX}/usr"
+
+SRC_TEST=do