summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-02-23 22:02:52 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-02-23 22:02:52 +0000
commit17aa47101d1973ef5876936d163fa03c1a26ba22 (patch)
treeb0da7fed84d6c3a2e6dff03b9ccaafc5a4be4263 /dev-ml/ocamlnet/ocamlnet-0.95.ebuild
parentnew package (keymasked) (diff)
downloadhistorical-17aa47101d1973ef5876936d163fa03c1a26ba22.tar.gz
historical-17aa47101d1973ef5876936d163fa03c1a26ba22.tar.bz2
historical-17aa47101d1973ef5876936d163fa03c1a26ba22.zip
new package
Diffstat (limited to 'dev-ml/ocamlnet/ocamlnet-0.95.ebuild')
-rw-r--r--dev-ml/ocamlnet/ocamlnet-0.95.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocamlnet/ocamlnet-0.95.ebuild b/dev-ml/ocamlnet/ocamlnet-0.95.ebuild
new file mode 100644
index 000000000000..abc22f5e31b6
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-0.95.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-0.95.ebuild,v 1.1 2003/02/23 22:02:52 george Exp $
+
+DESCRIPTION="Modules for O'Caml application-level Internet protocols"
+HOMEPAGE="http://ocamlnet.sourceforge.net"
+SRC_URI="mirror://sourceforge/ocamlnet/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-ml/pcre-ocaml-4.31.0
+ >=dev-ml/findlib-0.8"
+
+IUSE=""
+S="${WORKDIR}/${P}/src"
+
+src_compile() {
+ ./configure || die
+ make all opt || die
+}
+
+src_install() {
+ # must create destdir beforehand
+ destdir=`ocamlfind printconf destdir`
+ mkdir -p ${D}${destdir} || die
+ # install
+ make OCAMLFIND_DESTDIR=${D}${destdir} install || die
+
+ cd ${WORKDIR}/${P}
+ dodoc README
+ dohtml doc/intro/html/*
+}