summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-01-11 09:50:47 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-01-11 09:50:47 +0000
commitd320ec6cb62b1ddd95169629a0e8624185d1bd46 (patch)
tree44e68e0e5a47bccc9251ed3264910774c9265d0a /dev-lisp/clisp/clisp-2.31-r1.ebuild
parent*** empty log message *** (diff)
downloadhistorical-d320ec6cb62b1ddd95169629a0e8624185d1bd46.tar.gz
historical-d320ec6cb62b1ddd95169629a0e8624185d1bd46.tar.bz2
historical-d320ec6cb62b1ddd95169629a0e8624185d1bd46.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/clisp/clisp-2.31-r1.ebuild')
-rw-r--r--dev-lisp/clisp/clisp-2.31-r1.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/dev-lisp/clisp/clisp-2.31-r1.ebuild b/dev-lisp/clisp/clisp-2.31-r1.ebuild
index 3e6371c8c0ec..c14553444eb1 100644
--- a/dev-lisp/clisp/clisp-2.31-r1.ebuild
+++ b/dev-lisp/clisp/clisp-2.31-r1.ebuild
@@ -1,11 +1,21 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.31-r1.ebuild,v 1.1 2003/11/29 07:25:39 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.31-r1.ebuild,v 1.2 2004/01/11 09:50:39 mkennedy Exp $
inherit flag-o-matic
IUSE="X threads fastcgi postgres ldap nls"
+# Handle the case where the user has some other -falign-functions
+# option set. Bug 34630.
+
+if ! is-flag '-falign-functions=4' \
+ && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
+ CFLAGS=${CFLAGS/\
+$(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
+-falign-functions=4}
+fi
+
# Fails to compile without -falign-functions=4 when -march=pentium4
# (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
@@ -20,10 +30,8 @@ fi
if is-flag '-march=athlon-xp'; then
filter-flags '-O*'
-# replace-flags '-O3' '-O2'
fi
-
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
@@ -49,6 +57,7 @@ src_unpack() {
}
src_compile() {
+ einfo "Using CFLAGS: ${CFLAGS}"
export CC="${CC} ${CFLAGS}"
unset CFLAGS CXXFLAGS
local myconf="--with-dynamic-ffi