summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-09-26 05:01:53 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-09-26 05:01:53 +0000
commit5c53504c630391793385f8477ad26b030a6a89f7 (patch)
tree263d340d5e160a9f141a56f85e6cbe47aa1f2d49 /dev-lisp/cl-trivial-gray-streams/cl-trivial-gray-streams-20060925.ebuild
parentStable x86; its bashtastic (diff)
downloadhistorical-5c53504c630391793385f8477ad26b030a6a89f7.tar.gz
historical-5c53504c630391793385f8477ad26b030a6a89f7.tar.bz2
historical-5c53504c630391793385f8477ad26b030a6a89f7.zip
New upstream snapshot from CVS to support recent FLEXI-STREAMS.
Package-Manager: portage-2.1.1
Diffstat (limited to 'dev-lisp/cl-trivial-gray-streams/cl-trivial-gray-streams-20060925.ebuild')
-rw-r--r--dev-lisp/cl-trivial-gray-streams/cl-trivial-gray-streams-20060925.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lisp/cl-trivial-gray-streams/cl-trivial-gray-streams-20060925.ebuild b/dev-lisp/cl-trivial-gray-streams/cl-trivial-gray-streams-20060925.ebuild
new file mode 100644
index 000000000000..0c43dd8c5e34
--- /dev/null
+++ b/dev-lisp/cl-trivial-gray-streams/cl-trivial-gray-streams-20060925.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-trivial-gray-streams/cl-trivial-gray-streams-20060925.ebuild,v 1.1 2006/09/26 05:01:53 mkennedy Exp $
+
+inherit common-lisp
+
+MY_PV=${PV:0:4}-${PV:4:2}-${PV:6:2}
+MY_PN=${PN/cl-/}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A thin compatibility layer between Gray Stream Common Lisp implementations"
+HOMEPAGE="http://common-lisp.net/project/cl-plus-ssl/#trivial-gray-streams"
+SRC_URI="mirror://gentoo/trivial-gray-streams-${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND=""
+
+CLPACKAGE=trivial-gray-streams
+
+S=${WORKDIR}/trivial-gray-streams
+
+src_unpack() {
+ unpack ${A}
+ rm ${S}/Makefile
+}
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ dodoc README COPYING
+}