summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-16 20:49:51 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-16 20:49:51 +0000
commit87316522951397b3696e7ae8268648a6449825ee (patch)
tree9a9ac1a10119b7595873239dd5b08fa8180dd336 /dev-lisp/cl-lml2
parent*** empty log message *** (diff)
downloadhistorical-87316522951397b3696e7ae8268648a6449825ee.tar.gz
historical-87316522951397b3696e7ae8268648a6449825ee.tar.bz2
historical-87316522951397b3696e7ae8268648a6449825ee.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-lml2')
-rw-r--r--dev-lisp/cl-lml2/Manifest5
-rw-r--r--dev-lisp/cl-lml2/cl-lml2-1.4.1.ebuild36
-rw-r--r--dev-lisp/cl-lml2/files/digest-cl-lml2-1.4.11
-rw-r--r--dev-lisp/cl-lml2/metadata.xml5
4 files changed, 44 insertions, 3 deletions
diff --git a/dev-lisp/cl-lml2/Manifest b/dev-lisp/cl-lml2/Manifest
index 0592e222e0dd..53b2b71e7b33 100644
--- a/dev-lisp/cl-lml2/Manifest
+++ b/dev-lisp/cl-lml2/Manifest
@@ -1,5 +1,4 @@
-MD5 3130e79cfa27a0a6eb2dbf3e2d48c3e5 cl-lml2-1.4.1.ebuild~ 855
MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
-MD5 60956da6e5d93b898733bf237b4a946f cl-lml2-1.4.1.ebuild 904
-MD5 bab8b65d9fe2e9873809690b012a0387 ChangeLog 318
+MD5 1bded94436b0a4ba85c71e0147ef5b15 cl-lml2-1.4.1.ebuild 904
+MD5 3aa12877b878d973b23ea747cd6217e6 ChangeLog 318
MD5 4aed492f0cfd7414c3ae2d8fd98c7b88 files/digest-cl-lml2-1.4.1 61
diff --git a/dev-lisp/cl-lml2/cl-lml2-1.4.1.ebuild b/dev-lisp/cl-lml2/cl-lml2-1.4.1.ebuild
new file mode 100644
index 000000000000..0ac7b8e5c375
--- /dev/null
+++ b/dev-lisp/cl-lml2/cl-lml2-1.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-lml2/cl-lml2-1.4.1.ebuild,v 1.1 2003/10/16 20:45:27 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A Common Lisp package for generating HTML and XHTML documents"
+HOMEPAGE="http://www.b9.com"
+SRC_URI="ftp://ftp.b9.com/lml2/lml2-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=lml2
+
+S=${WORKDIR}/lml2-${PV}
+
+src_install() {
+ common-lisp-install *.lisp lml2.asd
+ common-lisp-system-symlink
+ dodoc README LICENSE ChangeLog
+ dohtml doc/readme.html
+ docinto examples
+ dodoc doc/make.lisp doc/Makefile doc/readme.lml
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
diff --git a/dev-lisp/cl-lml2/files/digest-cl-lml2-1.4.1 b/dev-lisp/cl-lml2/files/digest-cl-lml2-1.4.1
new file mode 100644
index 000000000000..cd9fff1f087c
--- /dev/null
+++ b/dev-lisp/cl-lml2/files/digest-cl-lml2-1.4.1
@@ -0,0 +1 @@
+MD5 18870b29ced39cd8e793187598e7ad5c lml2-1.4.1.tar.gz 27039
diff --git a/dev-lisp/cl-lml2/metadata.xml b/dev-lisp/cl-lml2/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-lml2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>