summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2003-03-13 22:27:16 +0000
committerGuy Martin <gmsoft@gentoo.org>2003-03-13 22:27:16 +0000
commit1d6ceb2ee6a857ef96304403e781fe0d90efa91a (patch)
tree0f994a16d6673483eb76261f1c9320e967abe2d9 /dev-libs
parentChangeLog doc (diff)
downloadhistorical-1d6ceb2ee6a857ef96304403e781fe0d90efa91a.tar.gz
historical-1d6ceb2ee6a857ef96304403e781fe0d90efa91a.tar.bz2
historical-1d6ceb2ee6a857ef96304403e781fe0d90efa91a.zip
Now produce libssl.so too for hppa.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/ChangeLog5
-rw-r--r--dev-libs/openssl/openssl-0.9.6i.ebuild11
-rw-r--r--dev-libs/openssl/openssl-0.9.7a.ebuild15
3 files changed, 16 insertions, 15 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index 8cc326b9b95f..ad64f1c30290 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/openssl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.30 2003/02/28 12:43:54 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.31 2003/03/13 22:27:16 gmsoft Exp $
+
+ 13 Mar 2003; Guy Martin <gmsoft@gento.org> openssl-0.9.6i.ebuild :
+ Now produce also libssl.so on hppa.
28 Feb 2003; Maarten Thibaut <murphy@gentoo.org> openssl-0.9.6i.ebuild :
Add code to detect sparc32 build on sparc64. Add code to compile for
diff --git a/dev-libs/openssl/openssl-0.9.6i.ebuild b/dev-libs/openssl/openssl-0.9.6i.ebuild
index 2925f04955dc..2bfd33eff2a1 100644
--- a/dev-libs/openssl/openssl-0.9.6i.ebuild
+++ b/dev-libs/openssl/openssl-0.9.6i.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.6i.ebuild,v 1.6 2003/03/11 21:11:45 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.6i.ebuild,v 1.7 2003/03/13 22:27:16 gmsoft Exp $
IUSE=""
@@ -30,16 +30,15 @@ src_unpack() {
patch -p1 < ${FILESDIR}/openssl-0.9.6-mips.diff || die
fi
- # many apps linking to openssl needs -fPIC
- if [ "${ARCH}" = "hppa" ]
- then
- CFLAGS="${CFLAGS} -fPIC"
- fi
if [ "${ARCH}" = "arm" ]; then
# patch linker to add -ldl or things linking aginst libcrypto fail
sed -e \
's!^"linux-elf-arm"\(.*\)::BN\(.*\)!"linux-elf-arm"\1:-ldl:BN\2!' \
Configure > Configure.orig
+ elif [ "${ARCH}" = "hppa" ]; then
+ sed -e \
+ 's!^"linux-parisc"\(.*\)::BN\(.*\)::!"linux-parisc"\1:-ldl:BN\2::::::::::dlfcn:linux-shared:-fPIC::.so.\\$(SHLIB_MAJOR).\\$(SHLIB_MINOR)!' \
+ Configure > Configure.orig
else
cp Configure Configure.orig
fi
diff --git a/dev-libs/openssl/openssl-0.9.7a.ebuild b/dev-libs/openssl/openssl-0.9.7a.ebuild
index 1d828d6ca643..5ecec687031f 100644
--- a/dev-libs/openssl/openssl-0.9.7a.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7a.ebuild,v 1.2 2003/03/11 21:11:45 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7a.ebuild,v 1.3 2003/03/13 22:27:16 gmsoft Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
@@ -33,14 +33,13 @@ src_unpack() {
patch -p1 < ${FILESDIR}/${P}-gentoo.diff
- # many apps linking to openssl needs -fPIC
- if [ "${ARCH}" = "hppa" ]
- then
- CFLAGS="${CFLAGS} -fPIC"
+ if [ "${ARCH}" = "hppa" ]; then
+ sed -e \
+ 's!^"linux-parisc"\(.*\)::BN\(.*\)::!"linux-parisc"\1:-ldl:BN\2::::::::::dlfcn:linux-shared:-fPIC::.so.\\$(SHLIB_MAJOR).\\$(SHLIB_MINOR)!' \
+ Configure > Configure.orig
+ else
+ cp Configure Configure.orig
fi
-
-
- cp Configure Configure.orig
sed -e "s/-O3/$CFLAGS/" -e "s/-m486//" Configure.orig > Configure
}