summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2010-11-21 06:24:07 +0000
committerRyan Hill <rhill@gentoo.org>2010-11-21 06:24:07 +0000
commit57d753c735e6805e4bfbc81da33a40fae0ea56fa (patch)
tree35edf3afb5059b941e5c515562a6a5ff15d1bfae /dev-libs/ppl/ppl-0.10.2-r1.ebuild
parentMask lpsol USE flag on archs w/o sci-mathematics/glpk keyworded. (diff)
downloadhistorical-57d753c735e6805e4bfbc81da33a40fae0ea56fa.tar.gz
historical-57d753c735e6805e4bfbc81da33a40fae0ea56fa.tar.bz2
historical-57d753c735e6805e4bfbc81da33a40fae0ea56fa.zip
Add lpsol USE for automagic dependency on sci-mathematics/glpk discovered in
bug #346173 by mehrunes. Push GMP patch to mirrors, bug #331051 by jer. Remove old. Package-Manager: portage-2.2.0_alpha4/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/ppl/ppl-0.10.2-r1.ebuild')
-rw-r--r--dev-libs/ppl/ppl-0.10.2-r1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-libs/ppl/ppl-0.10.2-r1.ebuild b/dev-libs/ppl/ppl-0.10.2-r1.ebuild
index 4bd2cfb381c5..e169859b0f6d 100644
--- a/dev-libs/ppl/ppl-0.10.2-r1.ebuild
+++ b/dev-libs/ppl/ppl-0.10.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ppl-0.10.2-r1.ebuild,v 1.10 2010/07/10 13:18:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ppl-0.10.2-r1.ebuild,v 1.11 2010/11/21 06:24:07 dirtyepic Exp $
EAPI=2
@@ -8,14 +8,16 @@ inherit autotools eutils
DESCRIPTION="The Parma Polyhedra Library provides numerical abstractions for analysis of complex systems"
HOMEPAGE="http://www.cs.unipr.it/ppl/"
-SRC_URI="http://www.cs.unipr.it/ppl/Download/ftp/releases/${PV}/${P}.tar.bz2"
+SRC_URI="http://www.cs.unipr.it/ppl/Download/ftp/releases/${PV}/${P}.tar.bz2
+ mirror://gentoo/${P}-gmp-5-fix.patch.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="doc pch test watchdog"
+IUSE="doc lpsol pch test watchdog"
-RDEPEND=">=dev-libs/gmp-4.1.3[-nocxx]"
+RDEPEND=">=dev-libs/gmp-4.1.3[-nocxx]
+ lpsol? ( sci-mathematics/glpk )"
DEPEND="${RDEPEND}
sys-devel/m4"
@@ -28,7 +30,7 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-gmp-5-fix.patch
+ epatch "${WORKDIR}"/${P}-gmp-5-fix.patch
eautoreconf
}
@@ -39,6 +41,7 @@ src_configure() {
--docdir=/usr/share/doc/${PF} \
--disable-debugging \
--disable-optimization \
+ $(use_enable lpsol ppl_lpsol) \
$(use_enable pch) \
$(use_enable watchdog) \
--enable-interfaces="c cxx" \