summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-11-26 13:57:35 +0000
committerAron Griffis <agriffis@gentoo.org>2003-11-26 13:57:35 +0000
commite49e50908128b14bc0c8fb7e16e89cc41269b718 (patch)
tree3fc70e29b421f8131b5353cc8ce5edc4a5a3aefd /dev-libs/librep/librep-0.17.ebuild
parentversion bump (diff)
downloadhistorical-e49e50908128b14bc0c8fb7e16e89cc41269b718.tar.gz
historical-e49e50908128b14bc0c8fb7e16e89cc41269b718.tar.bz2
historical-e49e50908128b14bc0c8fb7e16e89cc41269b718.zip
version bump
Diffstat (limited to 'dev-libs/librep/librep-0.17.ebuild')
-rw-r--r--dev-libs/librep/librep-0.17.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/librep/librep-0.17.ebuild b/dev-libs/librep/librep-0.17.ebuild
new file mode 100644
index 000000000000..3c1cd76e26fd
--- /dev/null
+++ b/dev-libs/librep/librep-0.17.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# # $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.17.ebuild,v 1.1 2003/11/26 13:57:31 agriffis Exp $
+
+IUSE="readline"
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Shared library implementing a Lisp dialect"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://librep.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~ia64"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ >=sys-devel/automake-1.6.1-r5"
+
+src_compile() {
+ elibtoolize
+
+ local myconf
+
+ use readline \
+ && myconf='--with-readline' \
+ || myconf='--without-readline'
+
+ LC_ALL=""
+ LINGUAS=""
+ LANG=""
+ export LC_ALL LINGUAS LANG
+
+ econf \
+ --libexecdir=/usr/lib \
+ --without-gmp \
+ ${myconf} || die "configure failure"
+
+ make host_type=${CHOST} || die "compile failure"
+}
+
+src_install() {
+ make install \
+ host_type=${CHOST} \
+ DESTDIR=${D} \
+ aclocaldir=/usr/share/aclocal \
+ infodir=/usr/share/info || die
+
+ insinto /usr/include
+ doins src/rep_config.h
+
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO DOC TREE
+ docinto doc
+ dodoc doc/*
+}