summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-04-03 10:37:18 +0000
committerPacho Ramos <pacho@gentoo.org>2011-04-03 10:37:18 +0000
commit9c6cfe863e5699242650000c7596cb21336c2b81 (patch)
treebecbc1de87e576a5f5e2cc2b0d638ffcabb4947f /dev-libs/liboobs/liboobs-3.0.0.ebuild
parentVersion bump. (diff)
downloadhistorical-9c6cfe863e5699242650000c7596cb21336c2b81.tar.gz
historical-9c6cfe863e5699242650000c7596cb21336c2b81.tar.bz2
historical-9c6cfe863e5699242650000c7596cb21336c2b81.zip
Version bump: link against OOBS_LIBS so strict linking works, store OobsUser's main group as GID rather than OobsGroup, remove idle tasks when destroying objects. Remove old.
Package-Manager: portage-2.1.9.45/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/liboobs/liboobs-3.0.0.ebuild')
-rw-r--r--dev-libs/liboobs/liboobs-3.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/liboobs/liboobs-3.0.0.ebuild b/dev-libs/liboobs/liboobs-3.0.0.ebuild
new file mode 100644
index 000000000000..e94bd8437ee6
--- /dev/null
+++ b/dev-libs/liboobs/liboobs-3.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liboobs/liboobs-3.0.0.ebuild,v 1.1 2011/04/03 10:37:18 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Liboobs is a wrapping library to the System Tools Backends."
+HOMEPAGE="http://library.gnome.org/devel/liboobs/stable/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+# FIXME: check if policykit should be checked in configure ?
+RDEPEND=">=dev-libs/glib-2.14:2
+ >=dev-libs/dbus-glib-0.70
+ >=app-admin/system-tools-backends-2.10.1"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --without-hal --disable-static"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}