summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2007-01-26 21:34:59 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2007-01-26 21:34:59 +0000
commitb7de3393c6e18737744b18ada05dba164d1964dc (patch)
treeda092d3c6ba818a74a1c6bfa96da37ede1fa4bb7 /dev-libs/libofx/libofx-0.7.0-r1.ebuild
parentUpdating 6.0.x to dep on tomcat-servlet-api. Modified patch to no longer buil... (diff)
downloadhistorical-b7de3393c6e18737744b18ada05dba164d1964dc.tar.gz
historical-b7de3393c6e18737744b18ada05dba164d1964dc.tar.bz2
historical-b7de3393c6e18737744b18ada05dba164d1964dc.zip
Re-add necessary version
Package-Manager: portage-2.1.2_rc4-r3
Diffstat (limited to 'dev-libs/libofx/libofx-0.7.0-r1.ebuild')
-rw-r--r--dev-libs/libofx/libofx-0.7.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libofx/libofx-0.7.0-r1.ebuild b/dev-libs/libofx/libofx-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..8b172c6e41c0
--- /dev/null
+++ b/dev-libs/libofx/libofx-0.7.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/libofx-0.7.0-r1.ebuild,v 1.3 2007/01/26 21:34:59 masterdriverz Exp $
+
+DESCRIPTION="Library to support the Open Financial eXchange XML Format"
+HOMEPAGE="http://libofx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libofx/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86"
+IUSE=""
+
+RDEPEND=">=app-text/opensp-1.5
+ >=net-misc/curl-7.9.7"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ # because we redefine docdir in src_install, we need to make sure the
+ # dtd's go to the right place, LIBOFX_DTD_DIR
+ cd ${S}/dtd
+ sed -i -e 's/$(DESTDIR)$(docdir)/$(DESTDIR)$(LIBOFX_DTD_DIR)/g' \
+ Makefile.in
+}
+
+src_install() {
+ dodir /usr/share/doc/${PF}
+ einstall docdir=${D}/usr/share/doc/${PF} || die
+}