summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-05 21:35:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-05 21:35:16 +0000
commit4590635dd794633ecfdc11d8fbd3329840acf48f (patch)
tree9befe87a9029fbb282e4eb1ebf12ff597c88f1de /dev-libs/icu
parentVersion bump. (diff)
downloadhistorical-4590635dd794633ecfdc11d8fbd3329840acf48f.tar.gz
historical-4590635dd794633ecfdc11d8fbd3329840acf48f.tar.bz2
historical-4590635dd794633ecfdc11d8fbd3329840acf48f.zip
Delete older ebuild.
Diffstat (limited to 'dev-libs/icu')
-rw-r--r--dev-libs/icu/icu-4.4-r1.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/dev-libs/icu/icu-4.4-r1.ebuild b/dev-libs/icu/icu-4.4-r1.ebuild
deleted file mode 100644
index 9806fcf5e71c..000000000000
--- a/dev-libs/icu/icu-4.4-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.4-r1.ebuild,v 1.1 2010/04/15 23:31:43 arfrever Exp $
-
-EAPI="3"
-
-inherit eutils flag-o-matic versionator
-
-MAJOR_MINOR_VERSION="$(get_version_component_range 1-2)"
-
-DESCRIPTION="International Components for Unicode"
-HOMEPAGE="http://www.icu-project.org/"
-
-BASE_URI="http://download.icu-project.org/files/icu4c/${PV}"
-DOCS_BASE_URI="http://download.icu-project.org/files/icu4c/${MAJOR_MINOR_VERSION}"
-SRC_ARCHIVE="icu4c-${PV//./_}-src.tgz"
-DOCS_ARCHIVE="icu4c-${MAJOR_MINOR_VERSION//./_}-docs.zip"
-
-SRC_URI="${BASE_URI}/${SRC_ARCHIVE}
- doc? ( ${DOCS_BASE_URI}/${DOCS_ARCHIVE} )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples"
-
-DEPEND="doc? ( app-arch/unzip )"
-RDEPEND=""
-
-S="${WORKDIR}/${PN}/source"
-
-QA_DT_NEEDED="/usr/lib.*/libicudata.so.${MAJOR_MINOR_VERSION/./}.0"
-
-src_unpack() {
- unpack "${SRC_ARCHIVE}"
- if use doc; then
- mkdir docs
- pushd docs > /dev/null
- unpack "${DOCS_ARCHIVE}"
- popd > /dev/null
- fi
-}
-
-src_prepare() {
- # Do not hardcode used CFLAGS, LDFLAGS etc. into icu-config
- # Bug 202059
- # https://bugs.icu-project.org/trac/ticket/6102
- for x in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
- sed -i -e "/^${x} =.*/s:@${x}@::" "config/Makefile.inc.in" || die "sed failed"
- done
-
- epatch "${FILESDIR}/${P}-install_libicutest.patch"
-}
-
-src_configure() {
- econf \
- --enable-static \
- $(use_enable debug) \
- $(use_enable examples samples)
-}
-
-src_test() {
- emake check || die "emake check failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dohtml ../readme.html
- dodoc ../unicode-license.txt
- if use doc; then
- insinto /usr/share/doc/${PF}/html/api
- doins -r "${WORKDIR}/docs/"*
- fi
-}