summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-07-05 16:05:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-07-05 16:05:07 +0000
commit9a57704878849afa06494e64d468863a661962ca (patch)
tree97364cc01e1bb07e0fffa4fbc9dcbd67e8f73961 /dev-libs/eventlog/eventlog-0.2.12.ebuild
parentInitial commit. (diff)
downloadhistorical-9a57704878849afa06494e64d468863a661962ca.tar.gz
historical-9a57704878849afa06494e64d468863a661962ca.tar.bz2
historical-9a57704878849afa06494e64d468863a661962ca.zip
version bump
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'dev-libs/eventlog/eventlog-0.2.12.ebuild')
-rw-r--r--dev-libs/eventlog/eventlog-0.2.12.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/eventlog/eventlog-0.2.12.ebuild b/dev-libs/eventlog/eventlog-0.2.12.ebuild
new file mode 100644
index 000000000000..fdd0e5950dc7
--- /dev/null
+++ b/dev-libs/eventlog/eventlog-0.2.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eventlog/eventlog-0.2.12.ebuild,v 1.1 2010/07/05 16:05:07 mr_bones_ Exp $
+
+EAPI=2
+inherit libtool eutils
+
+DESCRIPTION="Support library for syslog-ng"
+HOMEPAGE="http://www.balabit.com/products/syslog_ng/"
+SRC_URI="http://www.balabit.com/downloads/files/eventlog/0.2//eventlog_${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+DEPEND=""
+
+src_prepare() {
+ epunt_cxx
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS CREDITS ChangeLog NEWS PORTS README
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + \
+ || die "la removal failed"
+ fi
+}