summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-05-13 11:44:52 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-05-13 11:44:52 +0000
commit29b75827ba403af125b60b87fa21c13acb931791 (patch)
tree2cb722c71ae4ee562f76783f92ac97a6362c218b /dev-libs/dvenv
parentRevision bump; only install API docs if USE=doc and even then at least instal... (diff)
downloadhistorical-29b75827ba403af125b60b87fa21c13acb931791.tar.gz
historical-29b75827ba403af125b60b87fa21c13acb931791.tar.bz2
historical-29b75827ba403af125b60b87fa21c13acb931791.zip
Classes with virtual functions require virtual destructors.
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'dev-libs/dvenv')
-rw-r--r--dev-libs/dvenv/ChangeLog6
-rw-r--r--dev-libs/dvenv/dvenv-0.2.2-r1.ebuild5
-rw-r--r--dev-libs/dvenv/files/dvenv-0.2.2-virtual-dtors.diff27
3 files changed, 36 insertions, 2 deletions
diff --git a/dev-libs/dvenv/ChangeLog b/dev-libs/dvenv/ChangeLog
index 40ddb68c56d5..8517421be655 100644
--- a/dev-libs/dvenv/ChangeLog
+++ b/dev-libs/dvenv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/dvenv
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvenv/ChangeLog,v 1.7 2005/05/10 14:02:21 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvenv/ChangeLog,v 1.8 2005/05/13 11:44:52 ka0ttic Exp $
+
+ 13 May 2005; Aaron Walker <ka0ttic@gentoo.org>
+ +files/dvenv-0.2.2-virtual-dtors.diff, dvenv-0.2.2-r1.ebuild:
+ Classes with virtual functions require virtual destructors.
*dvenv-0.2.2-r1 (10 May 2005)
diff --git a/dev-libs/dvenv/dvenv-0.2.2-r1.ebuild b/dev-libs/dvenv/dvenv-0.2.2-r1.ebuild
index a25e2b4f4df6..4c7a0669966e 100644
--- a/dev-libs/dvenv/dvenv-0.2.2-r1.ebuild
+++ b/dev-libs/dvenv/dvenv-0.2.2-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvenv/dvenv-0.2.2-r1.ebuild,v 1.1 2005/05/10 14:02:21 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvenv/dvenv-0.2.2-r1.ebuild,v 1.2 2005/05/13 11:44:52 ka0ttic Exp $
+
+inherit eutils
DESCRIPTION="dvenv provides polymorphic tree-structured environments, generalizing the Dv::Util::Props class"
HOMEPAGE="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvenv/html/"
@@ -16,6 +18,7 @@ DEPEND="dev-libs/dvutil"
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/${P}-virtual-dtors.diff
sed -i 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' Makefile.in || \
die "sed Makefile.in failed"
}
diff --git a/dev-libs/dvenv/files/dvenv-0.2.2-virtual-dtors.diff b/dev-libs/dvenv/files/dvenv-0.2.2-virtual-dtors.diff
new file mode 100644
index 000000000000..f02449c633f7
--- /dev/null
+++ b/dev-libs/dvenv/files/dvenv-0.2.2-virtual-dtors.diff
@@ -0,0 +1,27 @@
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN dvenv-0.2.2.orig/dvenv/env.h dvenv-0.2.2/dvenv/env.h
+--- dvenv-0.2.2.orig/dvenv/env.h 2005-05-12 23:43:00.000000000 -0400
++++ dvenv-0.2.2/dvenv/env.h 2005-05-12 23:47:34.000000000 -0400
+@@ -596,6 +596,7 @@
+ class iterator {
+ public:
+ typedef std::map<std::string,const Env*>::iterator::value_type value_type;
++ virtual ~iterator() { }
+ virtual iterator& operator++();
+ virtual value_type operator*() const;
+ virtual bool equal(const iterator* i) const;
+@@ -721,6 +722,7 @@
+ class iterator: public Box::iterator {
+ public:
+ iterator(Map::const_iterator it): it_(it) {}
++ virtual ~iterator() { }
+ iterator& operator++() { ++it_; return *this; }
+ value_type operator*() const { return *it_; }
+ bool equal(const Box::iterator* i) const;
+@@ -763,6 +765,7 @@
+ class iterator: public Box::iterator {
+ public:
+ iterator(Vector::const_iterator it, const Vector* v);
++ virtual ~iterator() { }
+ iterator& operator++() { ++it_; return *this; }
+ value_type operator*() const;
+ bool equal(const Box::iterator* i) const;