summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-02-25 13:36:37 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-02-25 13:36:37 +0000
commite7cafcd8f460568240692fd6e84081f19ed626d9 (patch)
tree42d5b342e1dccf081fdd667005c00ebe2f10bd6f /dev-lang
parentSmall patch from bug #33243 (diff)
downloadhistorical-e7cafcd8f460568240692fd6e84081f19ed626d9.tar.gz
historical-e7cafcd8f460568240692fd6e84081f19ed626d9.tar.bz2
historical-e7cafcd8f460568240692fd6e84081f19ed626d9.zip
Reinstating portage version check as people keep upgrading python without upgrading portage.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/Manifest4
-rw-r--r--dev-lang/python/python-2.3.3.ebuild11
3 files changed, 11 insertions, 10 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index ed0dbc4a24ca..edeea6fffe86 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.82 2004/02/17 20:02:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.83 2004/02/25 13:36:37 kloeri Exp $
+
+ 25 Feb 2004; Bryan Østergaard,,, <kloeri@gentoo.org> python-2.3.3.ebuild:
+ Reinstating portage version check as people keep upgrading python without
+ upgrading portage.
17 Feb 2004; Aron Griffis <agriffis@gentoo.org> python-2.1.3-r1.ebuild:
Fix duplicate KEYWORDS settings and mark stable on alpha and ia64 for the sake
diff --git a/dev-lang/python/Manifest b/dev-lang/python/Manifest
index 47a9fb761c1c..cd4c72e4ee2a 100644
--- a/dev-lang/python/Manifest
+++ b/dev-lang/python/Manifest
@@ -1,9 +1,9 @@
MD5 93b7662124de176bfe45c4086578e583 python-2.2.3-r5.ebuild 4343
-MD5 8159f8c6a3f51448df6f07c881258258 python-2.3.3.ebuild 5839
+MD5 31f5cefe87f49598fb42d0f21ef754d7 python-2.3.3.ebuild 5675
MD5 a6b6753a28a9907d0743671073022f95 python-2.2.2.ebuild 3023
MD5 ca0918ca584b1f86c11131f3c8f18e2b python-2.1.3-r1.ebuild 2333
MD5 f7959cf61958991a7e25f83a4e8b2ff8 python-2.2.1-r5.ebuild 2912
-MD5 8b8eb5a0e53bbcfc40eaab9be22d6bb9 ChangeLog 14845
+MD5 d96c27ddda24f735f5ef536cebf99119 ChangeLog 15017
MD5 8145ce0144332d6caca98fa5fb648741 metadata.xml 221
MD5 ec16631b538a7481f0537191d5f23b27 files/python-2.3-mimetypes_apache.patch 454
MD5 85f269cd745feae3953f7e35215e242d files/python-updater 8138
diff --git a/dev-lang/python/python-2.3.3.ebuild b/dev-lang/python/python-2.3.3.ebuild
index c908dd419202..8224a98fd214 100644
--- a/dev-lang/python/python-2.3.3.ebuild
+++ b/dev-lang/python/python-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.16 2004/02/22 16:19:33 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.17 2004/02/25 13:36:37 kloeri Exp $
inherit flag-o-matic python
@@ -41,12 +41,9 @@ PROVIDE="virtual/python"
# this is to stop people shooting themselves in the foot. we can't
# add portage to DEPENDS otherwise it'll create a circular dependency
-# NOTE: we don't need this any more as sys-apps/portage-2.0.49-r18 is
-# already stable
-# NOTE2: OK, the reason this is _now_ disabled is because Gentoo 1.4
-# stage2 should upgrade fine to 2.3.3 even with the presence of
-# an old portage
-pkg_setup_disabled() {
+# NOTE from Koeri: I'm reinstating this check as people are upgrading python
+# without upgrading portage.
+pkg_setup() {
if ! has_version ">=sys-apps/portage-2.0.49-r16"; then
eerror "Dependency Failed! Requires >=sys-apps/portage-2.0.49-r16"
eerror "Please run: emerge portage"