summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2005-10-06 18:11:25 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2005-10-06 18:11:25 +0000
commite50f31ea8253fe410726a755a9faa959e460a02a (patch)
treef05808f9cdcce65159f929bf7c9fcdaa6c72da2c /dev-lang
parentXfce builds for new eclass and modular Xorg. (diff)
downloadhistorical-e50f31ea8253fe410726a755a9faa959e460a02a.tar.gz
historical-e50f31ea8253fe410726a755a9faa959e460a02a.tar.bz2
historical-e50f31ea8253fe410726a755a9faa959e460a02a.zip
Revert to using virtual/ghc in DEPEND since the other method had no advantages.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog5
-rw-r--r--dev-lang/ghc/Manifest10
-rw-r--r--dev-lang/ghc/ghc-6.4.1.ebuild21
3 files changed, 19 insertions, 17 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index c1649aad102b..8e9584db3292 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.71 2005/10/06 12:43:58 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.72 2005/10/06 18:11:25 dcoutts Exp $
+
+ 06 Oct 2005; <duncan@gentoo.org> ghc-6.4.1.ebuild:
+ Revert to using virtual/ghc in DEPEND since the other method had no advantages.
06 Oct 2005; <duncan@gentoo.org> +files/depsort.py, files/ghc-updater:
Make the ghc-updater script work better.
diff --git a/dev-lang/ghc/Manifest b/dev-lang/ghc/Manifest
index 50cf0f971ecd..29d4cc287acc 100644
--- a/dev-lang/ghc/Manifest
+++ b/dev-lang/ghc/Manifest
@@ -1,11 +1,11 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 e49767c6d695845b9a8bf406c519e2c4 ghc-6.4.1.ebuild 6084
+MD5 03c9b0a62d18142bfcbb57d84b154f4b ghc-6.4.1.ebuild 5943
MD5 6b0575f665b30bd942f60a152f52dca8 ghc-6.0.1.ebuild 4709
MD5 fe0e389aa3150e5fcfc59b4c5ff142cc ghc-6.2.2.ebuild 5581
MD5 9620778937a1aff6ef88863c81222cfc ghc-6.4.ebuild 6109
-MD5 51f33d5881e583634b7ef5d964b9fae9 ChangeLog 12799
+MD5 9dd2d4469df37616f8133d14b58a2ff7 ChangeLog 12935
MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
MD5 af174f2e566a288f0e2276883a866827 files/ghc-updater 9075
MD5 7e423c353b08a2c05693d13f21e067d0 files/depsort.py 1958
@@ -19,7 +19,7 @@ MD5 9c15b50bf0b73b7d70a06fd47510a3ef files/ghc-6.0.1.haddock.patch 380
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFDRRx/kyZuKN4EQ6YRAl0IAJwOb6G/mIn9izIGOyw59cPcQ2S0agCdFTyv
-dXPorTZypYLFxpGrF/7YU8E=
-=7KCW
+iD8DBQFDRWk4kyZuKN4EQ6YRAqXvAJ9ksXIfQJli88GKZXW16g27pQ1AxwCdFHWW
+jHd0YbivwOKwBf8/KV/OUd4=
+=FoYl
-----END PGP SIGNATURE-----
diff --git a/dev-lang/ghc/ghc-6.4.1.ebuild b/dev-lang/ghc/ghc-6.4.1.ebuild
index 02a08c2a88a7..6bec12c7a00b 100644
--- a/dev-lang/ghc/ghc-6.4.1.ebuild
+++ b/dev-lang/ghc/ghc-6.4.1.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.1.ebuild,v 1.4 2005/10/04 19:13:27 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.1.ebuild,v 1.5 2005/10/06 18:11:25 dcoutts Exp $
-# We abandon virtual/ghc in favor of || dependencies.
-# Here's a brief explanation of the new bootstrap logic:
+# Brief explanation of the bootstrap logic:
#
# ghc requires ghc-bin to bootstrap.
# Therefore,
-# (1) ghc depends on || (ghc-bin ghc)
-# (2) all packages that need ghc do the same
+# (1) both ghc-bin and ghc provide virtual/ghc
+# (2) virtual/ghc *must* default to ghc-bin
+# (3) ghc depends on virtual/ghc
#
-# Having the binary first everywhere doesn't force
-# anyone to do the full bootstrap. Still, ghc-bin can
-# be removed from a system after the first successful
-# install of ghc.
+# This solution has the advantage that the binary distribution
+# can be removed once an forall after the first succesful install
+# of ghc.
inherit base flag-o-matic eutils ghc-package
@@ -39,11 +38,11 @@ KEYWORDS="-alpha ~amd64 ~x86 ~sparc ~ppc"
S="${WORKDIR}/${MY_P}"
-# we still provide virtual/ghc to maintain compatibility for now
PROVIDE="virtual/ghc"
# ghc cannot usually be bootstrapped using later versions ...
-DEPEND="|| ( <=dev-lang/ghc-bin-6.5 <=dev-lang/ghc-6.5 )
+DEPEND="<virtual/ghc-6.5
+ !>=virtual/ghc-6.6*
>=dev-lang/perl-5.6.1
>=sys-devel/gcc-2.95.3
>=sys-devel/make-3.79.1