summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerbie Hopkins <herbs@gentoo.org>2005-07-06 23:32:21 +0000
committerHerbie Hopkins <herbs@gentoo.org>2005-07-06 23:32:21 +0000
commit0e420ec1338c43987f5caf9d4fded25445e24cf4 (patch)
tree3156055875d9fd70e7c054174cb34f59af58ec67 /dev-lang
parentremove stale ebuilds (diff)
downloadhistorical-0e420ec1338c43987f5caf9d4fded25445e24cf4.tar.gz
historical-0e420ec1338c43987f5caf9d4fded25445e24cf4.tar.bz2
historical-0e420ec1338c43987f5caf9d4fded25445e24cf4.zip
Multilib fixes.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog5
-rw-r--r--dev-lang/ocaml/Manifest14
-rw-r--r--dev-lang/ocaml/ocaml-3.08.3.ebuild12
3 files changed, 22 insertions, 9 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index bc1abd76d4f2..1deffb85c9b6 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.61 2005/05/10 22:26:52 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.62 2005/07/06 23:32:21 herbs Exp $
+
+ 06 Jul 2005; Herbie Hopkins <herbs@gentoo.org> ocaml-3.08.3.ebuild:
+ Multilib fixes.
11 May 2005; Matthieu Sozeau <mattam@gentoo.org> ocaml-3.08.3.ebuild:
Stable on ppc.
diff --git a/dev-lang/ocaml/Manifest b/dev-lang/ocaml/Manifest
index 7232b97da618..6e0e223a433b 100644
--- a/dev-lang/ocaml/Manifest
+++ b/dev-lang/ocaml/Manifest
@@ -1,9 +1,12 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 ede360aa66fcf54120c19798f0421e61 ocaml-3.08.ebuild 2209
MD5 e3554fd0d2b4cbd09694d68ca3edb0d8 ocaml-3.08.1.ebuild 2149
MD5 d3e28c5c99b056007b6b5b0781a4e542 ocaml-3.06-r2.ebuild 1660
MD5 ef7cc12a4ff8aeec9ddb58ff65f7e3c0 ocaml-3.07-r1.ebuild 2910
-MD5 f3a3095becc44092b9aa661ab3b85d27 ocaml-3.08.3.ebuild 2156
-MD5 90b9571c1ff7964e9008fa3838b6e420 ChangeLog 9847
+MD5 692d7dad58640c908f7d0ceaf7199b38 ocaml-3.08.3.ebuild 2204
+MD5 9db66d06a227d3fc07aa956bbc4499e7 ChangeLog 9935
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 4df214d6cd74b3c5955d868879dd6cc7 files/ocaml-3.06-tcltk-8.4compat-patch.bz2 639
MD5 8213fcf5533d0317af0486896b7afdd3 files/ocaml-rebuild.sh 1331
@@ -14,3 +17,10 @@ MD5 3854a7d6aaedc7d5fde7239776cec5cf files/digest-ocaml-3.08.1 66
MD5 d80f37fe859bc2ea8f71e13f02578275 files/digest-ocaml-3.08.3 66
MD5 77519cb4017543f060a963387b593299 files/digest-ocaml-3.08 65
MD5 91579cecf8659312c2324d8d40709433 files/ocaml-3.06-sparc-configure.patch 1660
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCzGon2G5bA0cA/ScRAgzbAKDBU2P1Mgo9pXkZWlN7lX+SxSwCmQCgkm/2
+o8auOy2s9/cQPriJotmkc64=
+=pjI6
+-----END PGP SIGNATURE-----
diff --git a/dev-lang/ocaml/ocaml-3.08.3.ebuild b/dev-lang/ocaml/ocaml-3.08.3.ebuild
index 337ff77d974f..693d1e20b747 100644
--- a/dev-lang/ocaml/ocaml-3.08.3.ebuild
+++ b/dev-lang/ocaml/ocaml-3.08.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.3.ebuild,v 1.2 2005/05/10 22:26:52 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.3.ebuild,v 1.3 2005/07/06 23:32:21 herbs Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils multilib
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
@@ -41,7 +41,7 @@ src_compile() {
./configure -prefix /usr \
-bindir /usr/bin \
- -libdir /usr/lib/ocaml \
+ -libdir /usr/$(get_libdir)/ocaml \
-mandir /usr/share/man \
--with-pthread ${myconf} || die
@@ -55,12 +55,12 @@ src_compile() {
src_install() {
make BINDIR=${D}/usr/bin \
- LIBDIR=${D}/usr/lib/ocaml \
+ LIBDIR=${D}/usr/$(get_libdir)/ocaml \
MANDIR=${D}/usr/share/man \
install || die
# silly, silly makefiles
- dosed "s:${D}::g" /usr/lib/ocaml/ld.conf
+ dosed "s:${D}::g" /usr/$(get_libdir)/ocaml/ld.conf
# documentation
dodoc Changes INSTALL LICENSE README Upgrading
@@ -68,7 +68,7 @@ src_install() {
pkg_postinst() {
if use latex; then
- echo "TEXINPUTS=/usr/lib/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
fi
echo