summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2004-04-24 19:00:40 +0000
committerIan Leitch <port001@gentoo.org>2004-04-24 19:00:40 +0000
commit916e211c3847202c0be07d8814d2e131d9151d57 (patch)
tree6010e7910379c82209e008841c1823506c4fdb6f /dev-lang/tk
parentversion bump, bug 47435. (diff)
downloadhistorical-916e211c3847202c0be07d8814d2e131d9151d57.tar.gz
historical-916e211c3847202c0be07d8814d2e131d9151d57.tar.bz2
historical-916e211c3847202c0be07d8814d2e131d9151d57.zip
Enable threads with local USE flag 'threads'. #2024
Diffstat (limited to 'dev-lang/tk')
-rw-r--r--dev-lang/tk/ChangeLog6
-rw-r--r--dev-lang/tk/Manifest6
-rw-r--r--dev-lang/tk/tk-8.3.4-r1.ebuild30
-rw-r--r--dev-lang/tk/tk-8.4.6.ebuild30
4 files changed, 64 insertions, 8 deletions
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index fcfede6aafcf..d5af659f3864 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/tk
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.31 2004/04/20 09:49:31 port001 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.32 2004/04/24 19:00:40 port001 Exp $
+
+ 24 Apr 2004; Ian Leitch <port001@gentoo.org> tk-8.3.4-r1.ebuild,
+ tk-8.4.6.ebuild:
+ Enable threads with local USE flag 'threads'. #2024
20 Apr 2004; Ian Leitch <port001@gentoo.org> tk-8.4.6.ebuild:
Marked stable on amd64
diff --git a/dev-lang/tk/Manifest b/dev-lang/tk/Manifest
index f1b3668778a7..7a93d0508263 100644
--- a/dev-lang/tk/Manifest
+++ b/dev-lang/tk/Manifest
@@ -1,6 +1,6 @@
-MD5 97720cf062d7a3712f1141dc2d3b740f tk-8.3.4-r1.ebuild 2003
-MD5 3cb6901c2c1c7000c2849599c70617a6 tk-8.4.6.ebuild 2000
-MD5 0d05d2242963090d0b439be6b220a7c0 ChangeLog 4657
+MD5 81b0382694513889c0f062db971a200b tk-8.3.4-r1.ebuild 2437
+MD5 84a128c44958f92bceb0f4ccade533c2 tk-8.4.6.ebuild 2431
+MD5 26bd57f32728e59149d75fa7517cfa6a ChangeLog 4798
MD5 0321d3bb5b70142a415de40ae2d5e3d4 files/digest-tk-8.3.4-r1 192
MD5 f64532dbe89c04cefe0e16a9743f5f57 files/digest-tk-8.4.6 64
MD5 3e8db8239fe4e68f5107a7a1d4f2f85b files/remove-control-v.diff 400
diff --git a/dev-lang/tk/tk-8.3.4-r1.ebuild b/dev-lang/tk/tk-8.3.4-r1.ebuild
index a9ff43c8ef87..d29fb63a14a9 100644
--- a/dev-lang/tk/tk-8.3.4-r1.ebuild
+++ b/dev-lang/tk/tk-8.3.4-r1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.4-r1.ebuild,v 1.6 2004/01/03 18:37:24 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.4-r1.ebuild,v 1.7 2004/04/24 19:00:40 port001 Exp $
inherit eutils
+IUSE="threads"
+
DESCRIPTION="Tk Widget Set"
HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_3/${PN}${PV}.tar.gz"
@@ -19,6 +21,21 @@ DEPEND=">=sys-apps/sed-4.0.5
S=${WORKDIR}/${PN}${PV}
+pkg_setup() {
+
+ if [ "`use threads`" ]
+ then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling ${P} with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications"
+ ewarn "that compile against tcl. You use threading at"
+ ewarn "your own discretion."
+ ewarn ""
+ sleep 5
+ fi
+}
+
src_unpack() {
unpack ${A}
cd ${S}/library
@@ -29,9 +46,18 @@ src_unpack() {
#
src_compile() {
cd ${S}/unix
+
+ local local_config_use=""
+
+ if [ "`use threads`" ]
+ then
+ local_config_use="--enable-threads"
+ fi
+
econf \
--with-tcl=/usr/lib \
- --enable-threads || die
+ ${local_config_use} || die
+
emake CFLAGS="${CFLAGS}" || die
}
diff --git a/dev-lang/tk/tk-8.4.6.ebuild b/dev-lang/tk/tk-8.4.6.ebuild
index d6e126e81e08..6e3ce76f8b66 100644
--- a/dev-lang/tk/tk-8.4.6.ebuild
+++ b/dev-lang/tk/tk-8.4.6.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.6.ebuild,v 1.3 2004/04/20 09:49:31 port001 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.6.ebuild,v 1.4 2004/04/24 19:00:40 port001 Exp $
inherit eutils
+IUSE="threads"
+
DESCRIPTION="Tk Widget Set"
HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
@@ -20,6 +22,21 @@ DEPEND=">=sys-apps/sed-4.0.5
S=${WORKDIR}/${PN}${PV}
+pkg_setup() {
+
+ if [ "`use threads`" ]
+ then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling ${P} with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications"
+ ewarn "that compile against tcl. You use threading at"
+ ewarn "your own discretion."
+ ewarn ""
+ sleep 5
+ fi
+}
+
src_unpack() {
unpack ${A}
cd ${S}/library
@@ -28,9 +45,18 @@ src_unpack() {
src_compile() {
cd ${S}/unix
+
+ local local_config_use=""
+
+ if [ "`use threads`" ]
+ then
+ local_config_use="--enable-threads"
+ fi
+
econf \
--with-tcl=/usr/lib \
- --enable-threads || die
+ ${local_config_use} || die
+
emake CFLAGS="${CFLAGS}" || die
}