summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-04 05:46:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-04 05:46:03 +0000
commit3659dc57a02badbd4a0e34a98d3c2c697e604e6e (patch)
tree0f2a9ae537ade295bd6a841a1038c2a4bfe66f8f /dev-lang/python/python-3.1.ebuild
parentx86 stable, bug #278543 (diff)
downloadhistorical-3659dc57a02badbd4a0e34a98d3c2c697e604e6e.tar.gz
historical-3659dc57a02badbd4a0e34a98d3c2c697e604e6e.tar.bz2
historical-3659dc57a02badbd4a0e34a98d3c2c697e604e6e.zip
Fix building with sys-libs/db headers containing non-UTF-8 characters (bug #280001).
Package-Manager: portage-13887-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-lang/python/python-3.1.ebuild')
-rw-r--r--dev-lang/python/python-3.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.1.ebuild b/dev-lang/python/python-3.1.ebuild
index 5da86bb86aa2..ffc1ba01498b 100644
--- a/dev-lang/python/python-3.1.ebuild
+++ b/dev-lang/python/python-3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.ebuild,v 1.1 2009/08/01 21:47:32 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.ebuild,v 1.2 2009/08/04 05:46:03 arfrever Exp $
EAPI="2"
@@ -73,6 +73,9 @@ src_prepare() {
# that stdin is a tty for bug #248081.
sed -e "s:'osf1V5':'osf1V5' and sys.stdin.isatty():" -i Lib/test/test_file.py || die "sed failed"
+ # Ignore non-UTF-8 characters (bug #280001)
+ sed -e "s/f = open(f)\.read()/f = open(f, errors='replace').read()/" -i setup.py || die "sed failed"
+
eautoreconf
}