summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-04-27 12:18:26 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-04-27 12:18:26 +0000
commit830ff1a8db5c3e9256a9ed1fc28ef104be08db15 (patch)
treef181e309709232e13b3003dc067a4df86454a8f1 /dev-lang/python/files/python-2.4.1-db4.patch
parentstable bump (diff)
downloadhistorical-830ff1a8db5c3e9256a9ed1fc28ef104be08db15.tar.gz
historical-830ff1a8db5c3e9256a9ed1fc28ef104be08db15.tar.bz2
historical-830ff1a8db5c3e9256a9ed1fc28ef104be08db15.zip
version bump for 2.4.1, clean up readling, db4 and libdir patch for 2.4.1.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-lang/python/files/python-2.4.1-db4.patch')
-rw-r--r--dev-lang/python/files/python-2.4.1-db4.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lang/python/files/python-2.4.1-db4.patch b/dev-lang/python/files/python-2.4.1-db4.patch
new file mode 100644
index 000000000000..8fb24957efe5
--- /dev/null
+++ b/dev-lang/python/files/python-2.4.1-db4.patch
@@ -0,0 +1,35 @@
+--- setup.py.old 2005-04-26 15:10:52.306357556 +0100
++++ setup.py 2005-04-26 15:13:56.855313581 +0100
+@@ -505,27 +505,13 @@
+ # construct a list of paths to look for the header file in on
+ # top of the normal inc_dirs.
+ db_inc_paths = [
++ '/usr/include/db4.3',
++ '/usr/include/db4.2',
++ '/usr/include/db4.1',
+ '/usr/include/db4',
+- '/usr/local/include/db4',
+- '/opt/sfw/include/db4',
+- '/sw/include/db4',
+- '/usr/include/db3',
+- '/usr/local/include/db3',
+- '/opt/sfw/include/db3',
+- '/sw/include/db3',
++ '/usr/include/db3.2',
++ '/usr/include/db3',
+ ]
+- # 4.x minor number specific paths
+- for x in (0,1,2,3):
+- db_inc_paths.append('/usr/include/db4%d' % x)
+- db_inc_paths.append('/usr/local/BerkeleyDB.4.%d/include' % x)
+- db_inc_paths.append('/usr/local/include/db4%d' % x)
+- db_inc_paths.append('/pkg/db-4.%d/include' % x)
+- # 3.x minor number specific paths
+- for x in (2,3):
+- db_inc_paths.append('/usr/include/db3%d' % x)
+- db_inc_paths.append('/usr/local/BerkeleyDB.3.%d/include' % x)
+- db_inc_paths.append('/usr/local/include/db3%d' % x)
+- db_inc_paths.append('/pkg/db-3.%d/include' % x)
+
+ db_ver_inc_map = {}
+