summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-05-04 00:53:07 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-05-04 00:53:07 +0000
commit7494808b2206f79579c7c3eb6f18d88af54a38fd (patch)
tree53373ff7fd810f0e85bca8babc0759ef994c2943 /dev-lang/mmix/mmix-20020216.ebuild
parentThe tilde may break portage 1.8.8, but the asterisks break portage (diff)
downloadhistorical-7494808b2206f79579c7c3eb6f18d88af54a38fd.tar.gz
historical-7494808b2206f79579c7c3eb6f18d88af54a38fd.tar.bz2
historical-7494808b2206f79579c7c3eb6f18d88af54a38fd.zip
Fixes #2075.
Diffstat (limited to 'dev-lang/mmix/mmix-20020216.ebuild')
-rw-r--r--dev-lang/mmix/mmix-20020216.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-lang/mmix/mmix-20020216.ebuild b/dev-lang/mmix/mmix-20020216.ebuild
new file mode 100644
index 000000000000..13260b9acbe3
--- /dev/null
+++ b/dev-lang/mmix/mmix-20020216.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Hanno Boeck <hanno@gmx.de>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/mmix-20020216.ebuild,v 1.1 2002/05/04 00:53:07 karltk Exp $
+
+S=${WORKDIR}
+DESCRIPTION="Donald Knuth's MMIX Assembler and Simulator"
+SRC_URI="http://www-cs-faculty.stanford.edu/~knuth/programs/mmix.tar.gz"
+HOMEPAGE="http://www-cs-faculty.stanford.edu/~knuth/mmix.html"
+
+DEPEND="virtual/glibc
+ >=dev-util/cweb-3.63"
+RDEPEND="$DEPEND"
+
+src_compile() {
+ make basic CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ dobin mmix mmixal
+ doman mmix.1
+ dodoc README
+}