summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-05-14 06:15:18 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-05-14 06:15:18 +0000
commit9b95e6450d20df1eb29addbd1ae35abb19bc00ba (patch)
treeb1457c32e774701d28cf2490f4e28c829256f9ca /dev-java
parentInitial import. Closes #15106. (diff)
downloadhistorical-9b95e6450d20df1eb29addbd1ae35abb19bc00ba.tar.gz
historical-9b95e6450d20df1eb29addbd1ae35abb19bc00ba.tar.bz2
historical-9b95e6450d20df1eb29addbd1ae35abb19bc00ba.zip
Initial import. Closes #15106.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/saxon/Manifest7
-rw-r--r--dev-java/saxon/files/digest-saxon-6.5.21
-rw-r--r--dev-java/saxon/files/digest-saxon-7.3.11
-rw-r--r--dev-java/saxon/files/digest-saxon-7.51
-rw-r--r--dev-java/saxon/saxon-6.5.2.ebuild25
-rw-r--r--dev-java/saxon/saxon-7.3.1.ebuild25
-rw-r--r--dev-java/saxon/saxon-7.5.ebuild25
7 files changed, 82 insertions, 3 deletions
diff --git a/dev-java/saxon/Manifest b/dev-java/saxon/Manifest
index 2b8bf364b167..8831e9fc0351 100644
--- a/dev-java/saxon/Manifest
+++ b/dev-java/saxon/Manifest
@@ -1,6 +1,7 @@
-MD5 57ed98c4c37e7c68bdd4aef81bb67d8d saxon-6.5.2.ebuild 605
-MD5 7d412d0da07f418b68e82c1b2339c5ad saxon-7.3.1.ebuild 608
-MD5 7d412d0da07f418b68e82c1b2339c5ad saxon-7.5.ebuild 608
+MD5 7644dee06cc0c34e7b403a3f8a755e79 saxon-6.5.2.ebuild 712
+MD5 87e7b5cebcfccd4e373b6d8eb66b68f9 saxon-7.3.1.ebuild 715
+MD5 61a26d039c3915cfdac83fd95ec40da2 saxon-7.5.ebuild 713
+MD5 a6ee4168e02a09a483f80e68b1e3a8ad ChangeLog 368
MD5 8677174400a1ffc2be67eecbf2900594 files/digest-saxon-7.5 58
MD5 21bfbc79426b598f49e48b0c63dc7e01 files/digest-saxon-6.5.2 60
MD5 cf12369ef491423c85be9aac02792eb0 files/digest-saxon-7.3.1 60
diff --git a/dev-java/saxon/files/digest-saxon-6.5.2 b/dev-java/saxon/files/digest-saxon-6.5.2
new file mode 100644
index 000000000000..841bd9f62ee5
--- /dev/null
+++ b/dev-java/saxon/files/digest-saxon-6.5.2
@@ -0,0 +1 @@
+MD5 6a822530943cc9ddff45ed4d77413d89 saxon6_5_2.zip 3088550
diff --git a/dev-java/saxon/files/digest-saxon-7.3.1 b/dev-java/saxon/files/digest-saxon-7.3.1
new file mode 100644
index 000000000000..15c1fa278ee3
--- /dev/null
+++ b/dev-java/saxon/files/digest-saxon-7.3.1
@@ -0,0 +1 @@
+MD5 230c6b8416cadacca7221b21017bbd53 saxon7-3-1.zip 3709256
diff --git a/dev-java/saxon/files/digest-saxon-7.5 b/dev-java/saxon/files/digest-saxon-7.5
new file mode 100644
index 000000000000..8f13992bb04b
--- /dev/null
+++ b/dev-java/saxon/files/digest-saxon-7.5
@@ -0,0 +1 @@
+MD5 3a7e741ce238347b8315a17963f755f9 saxon7-5.zip 4080920
diff --git a/dev-java/saxon/saxon-6.5.2.ebuild b/dev-java/saxon/saxon-6.5.2.ebuild
new file mode 100644
index 000000000000..25ba84dd7478
--- /dev/null
+++ b/dev-java/saxon/saxon-6.5.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/saxon/saxon-6.5.2.ebuild,v 1.1 2003/05/14 06:15:13 absinthe Exp $
+
+inherit java-pkg
+
+S=${WORKDIR}
+DESCRIPTION="The SAXON package is a collection of tools for processing XML documents: XSLT processor, XSL library, parser."
+SRC_URI="mirror://sourceforge/saxon/saxon${PV//./_}.zip"
+HOMEPAGE="http://saxon.sourceforge.net/"
+LICENSE="MPL-1.1"
+KEYWORDS="x86 sparc ppc"
+IUSE="doc"
+DEPEND=""
+RDEPEND="virtual/jdk"
+SLOT="0"
+
+src_compile() {
+ einfo "This is a binary-only ebuild (for now)."
+}
+
+src_install() {
+ use doc && dohtml -r doc/*
+ java-pkg_dojar *.jar
+}
diff --git a/dev-java/saxon/saxon-7.3.1.ebuild b/dev-java/saxon/saxon-7.3.1.ebuild
new file mode 100644
index 000000000000..10f6cbe3b581
--- /dev/null
+++ b/dev-java/saxon/saxon-7.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/saxon/saxon-7.3.1.ebuild,v 1.1 2003/05/14 06:15:13 absinthe Exp $
+
+inherit java-pkg
+
+S=${WORKDIR}
+DESCRIPTION="The SAXON package is a collection of tools for processing XML documents: XSLT processor, XSL library, parser."
+SRC_URI="mirror://sourceforge/saxon/saxon${PV//./-}.zip"
+HOMEPAGE="http://saxon.sourceforge.net/"
+LICENSE="MPL-1.1"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE="doc"
+DEPEND=""
+RDEPEND="virtual/jdk"
+SLOT="0"
+
+src_compile() {
+ einfo "This is a binary-only ebuild (for now)."
+}
+
+src_install() {
+ use doc && dohtml -r doc/*
+ java-pkg_dojar *.jar
+}
diff --git a/dev-java/saxon/saxon-7.5.ebuild b/dev-java/saxon/saxon-7.5.ebuild
new file mode 100644
index 000000000000..e97ee4e6f8ae
--- /dev/null
+++ b/dev-java/saxon/saxon-7.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/saxon/saxon-7.5.ebuild,v 1.1 2003/05/14 06:15:13 absinthe Exp $
+
+inherit java-pkg
+
+S=${WORKDIR}
+DESCRIPTION="The SAXON package is a collection of tools for processing XML documents: XSLT processor, XSL library, parser."
+SRC_URI="mirror://sourceforge/saxon/saxon${PV//./-}.zip"
+HOMEPAGE="http://saxon.sourceforge.net/"
+LICENSE="MPL-1.1"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE="doc"
+DEPEND=""
+RDEPEND="virtual/jdk"
+SLOT="0"
+
+src_compile() {
+ einfo "This is a binary-only ebuild (for now)."
+}
+
+src_install() {
+ use doc && dohtml -r doc/*
+ java-pkg_dojar *.jar
+}