summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-11-02 21:59:58 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-11-02 21:59:58 +0000
commit69e0ab03d4114a3f10dcdb66a1656566553d7dd0 (patch)
treea34fa3fcda549fbf2ca4ce59507968ca2f03a909 /dev-java
parentupdate thanks hano (diff)
downloadhistorical-69e0ab03d4114a3f10dcdb66a1656566553d7dd0.tar.gz
historical-69e0ab03d4114a3f10dcdb66a1656566553d7dd0.tar.bz2
historical-69e0ab03d4114a3f10dcdb66a1656566553d7dd0.zip
Fixes #10099.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-pool/ChangeLog8
-rw-r--r--dev-java/commons-pool/commons-pool-1.0.1-r2.ebuild50
-rw-r--r--dev-java/commons-pool/files/digest-commons-pool-1.0.1-r21
3 files changed, 58 insertions, 1 deletions
diff --git a/dev-java/commons-pool/ChangeLog b/dev-java/commons-pool/ChangeLog
index f0ac2c86844b..babf38f40334 100644
--- a/dev-java/commons-pool/ChangeLog
+++ b/dev-java/commons-pool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-pool
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.2 2002/11/01 18:12:07 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.3 2002/11/02 21:59:58 karltk Exp $
+
+*commons-pool-1.0.1-r2 (02 Nov 2002)
+
+ 02 Nov 2002; Karl Trygve Kalleberg <karltk@gentoo.org> commons-pool-1.0.1-r2.ebuild files/digest-commons-pool-1.0.1-r2 :
+ Added Jikes compilation support. Ebuild submitted by Adrian Almenar
+ <aalmenar@conectium.com>.
*commons-pool-1.0.1-r1 (01 Nov 2002)
diff --git a/dev-java/commons-pool/commons-pool-1.0.1-r2.ebuild b/dev-java/commons-pool/commons-pool-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..43c52c269a88
--- /dev/null
+++ b/dev-java/commons-pool/commons-pool-1.0.1-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.0.1-r2.ebuild,v 1.1 2002/11/02 21:59:58 karltk Exp $
+
+S=${WORKDIR}/${PN}-${PV}-src
+DESCRIPTION="Jakarta-Commons component providing general purpose object pooling API"
+HOMEPAGE="http://jakarta.apache.org/commons/pool.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ >=dev-java/commons-collections-2.0
+ junit? ( >=junit-3.7 )"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/commons-collections-2.0"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+IUSE="jikes junit"
+
+src_compile() {
+ local myc
+
+ echo "commons-collections.jar=`java-config --classpath=commons-collections`" > build.properties
+
+ if [ -n "`use jikes`" ] ; then
+ myc="${myc} -Dbuild.compiler=jikes"
+ fi
+
+ if [ -n "`use junit`" ] ; then
+ echo "junit.jar=`java-config --classpath=junit`" >> build.properties
+ ANT_OPTS=${myc} ant || die "Testing Classes Failed"
+ fi
+
+ ANT_OPTS=${myc} ant dist-jar || die "Compilation Failed"
+ ANT_OPTS=${myc} ant doc || die "Unable to create documents"
+}
+
+src_install () {
+ dojar dist/${PN}*.jar || die "Unable to install"
+ dodoc README.txt
+ dohtml STATUS.html PROPOSAL.html
+ dohtml -r dist/docs/*
+}
+
+pkg_postinst() {
+ einfo "************* Documentation can be found at **************\n
+ WEB: ${HOMEPAGE}\n
+ LOCAL: /usr/share/doc/${PF}\n
+ **********************************************************"
+}
diff --git a/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r2 b/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r2
new file mode 100644
index 000000000000..0532b13e26a7
--- /dev/null
+++ b/dev-java/commons-pool/files/digest-commons-pool-1.0.1-r2
@@ -0,0 +1 @@
+MD5 df9aaf5ee3e5d68abbee6eca0b8d037f commons-pool-1.0.1-src.tar.gz 62093