summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2013-04-08 16:46:02 +0000
committerRalph Sennhauser <sera@gentoo.org>2013-04-08 16:46:02 +0000
commitfc2a064169127a8fc6a8f68deee69ff53b7b3a54 (patch)
treed38d35270ff9223c4b2b7a63e72a7d2f09fdf93d /dev-java/java-config/java-config-2.2.0.ebuild
parentNew package containing the Java projects eselect modules formerly in java-con... (diff)
downloadhistorical-fc2a064169127a8fc6a8f68deee69ff53b7b3a54.tar.gz
historical-fc2a064169127a8fc6a8f68deee69ff53b7b3a54.tar.bz2
historical-fc2a064169127a8fc6a8f68deee69ff53b7b3a54.zip
bug 455798: Use recorded VM dependency for launcher
bug 402315: Don't lock on active VM in presence of virtuals. bug 464608: Make Portage dependency explicit. ROOT support. Gentoo Prefix support. Install man page. Eselect modules and run-java-tool are split-out into separate package eselect-java. Desktop files, icons, env.d and profile.d files as well as revdep-rebuild control file now part of baselayout-java. Fix running tests. Package-Manager: portage-2.1.11.60/cvs/Linux x86_64 Manifest-Sign-Key: 0x3C5CF75A
Diffstat (limited to 'dev-java/java-config/java-config-2.2.0.ebuild')
-rw-r--r--dev-java/java-config/java-config-2.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/java-config/java-config-2.2.0.ebuild b/dev-java/java-config/java-config-2.2.0.ebuild
new file mode 100644
index 000000000000..26e773eae176
--- /dev/null
+++ b/dev-java/java-config/java-config-2.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/java-config-2.2.0.ebuild,v 1.1 2013/04/08 16:45:48 sera Exp $
+
+EAPI="5"
+
+# jython depends on java-config, so don't add it or things will break
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Java environment configuration query tool"
+HOMEPAGE="http://www.gentoo.org/proj/en/java/"
+SRC_URI="http://dev.gentoo.org/~sera/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+# baselayout-java is added as a dep till it can be added to eclass.
+RDEPEND="
+ >=dev-java/java-config-wrapper-0.15
+ sys-apps/baselayout-java
+ sys-apps/portage"
+
+python_test() {
+ esetup.py test || die
+}