summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2011-04-08 13:15:30 +0000
committerVlastimil Babka <caster@gentoo.org>2011-04-08 13:15:30 +0000
commit212e2be0396669739692bd35c29b04e26b702dd1 (patch)
treefda26bdedb5fcdb6835d3c4b612ec83d2c3b3b16 /dev-java/icedtea-web
parentVersion bump, bug #361921. Restrict libpng deps on older versions. (diff)
downloadhistorical-212e2be0396669739692bd35c29b04e26b702dd1.tar.gz
historical-212e2be0396669739692bd35c29b04e26b702dd1.tar.bz2
historical-212e2be0396669739692bd35c29b04e26b702dd1.zip
Version bump, bug #361921.
Package-Manager: portage-2.2.0_alpha28/cvs/Linux x86_64
Diffstat (limited to 'dev-java/icedtea-web')
-rw-r--r--dev-java/icedtea-web/ChangeLog7
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.0.2.ebuild119
2 files changed, 125 insertions, 1 deletions
diff --git a/dev-java/icedtea-web/ChangeLog b/dev-java/icedtea-web/ChangeLog
index cf92db0946cf..6f1b901c6be9 100644
--- a/dev-java/icedtea-web/ChangeLog
+++ b/dev-java/icedtea-web/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/icedtea-web
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.3 2011/03/30 19:54:38 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.4 2011/04/08 13:15:30 caster Exp $
+
+*icedtea-web-1.0.2 (08 Apr 2011)
+
+ 08 Apr 2011; Vlastimil Babka <caster@gentoo.org> +icedtea-web-1.0.2.ebuild:
+ Version bump, bug #361921.
30 Mar 2011; Vlastimil Babka <caster@gentoo.org> icedtea-web-1.0.1.ebuild:
Remove -j1 from src_install as there should be no problem now that
diff --git a/dev-java/icedtea-web/icedtea-web-1.0.2.ebuild b/dev-java/icedtea-web/icedtea-web-1.0.2.ebuild
new file mode 100644
index 000000000000..96ac184ab4a6
--- /dev/null
+++ b/dev-java/icedtea-web/icedtea-web-1.0.2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.0.2.ebuild,v 1.1 2011/04/08 13:15:30 caster Exp $
+# Build written by Andrew John Hughes (ahughes@redhat.com)
+
+EAPI="2"
+
+inherit eutils java-pkg-2 java-vm-2
+
+LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
+SLOT="6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
+SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.gz"
+HOMEPAGE="http://icedtea.classpath.org"
+
+IUSE="doc +nsplugin"
+
+RDEPEND="dev-java/icedtea:6
+ nsplugin? ( >=net-libs/xulrunner-1.9.1 )"
+DEPEND="${RDEPEND}"
+
+# a bit of hack so the VM switching is triggered without causing dependency troubles
+JAVA_PKG_NV_DEPEND=">=virtual/jdk-1.6"
+JAVA_PKG_WANT_SOURCE="1.6"
+JAVA_PKG_WANT_TARGET="1.6"
+
+pkg_setup() {
+ # quite a hack since java-config does not provide a way for a package
+ # to limit supported VM's for building and their preferred order
+ if [[ -n "${JAVA_PKG_FORCE_VM}" ]]; then
+ einfo "Honoring user-set JAVA_PKG_FORCE_VM"
+ elif has_version dev-java/icedtea:6; then
+ JAVA_PKG_FORCE_VM="icedtea6"
+ else
+ JAVA_PKG_FORCE_VM=""
+ # don't die just yet if merging a binpkg - bug #258423
+ DIE_IF_NOT_BINPKG=true
+ fi
+
+ # if the previous failed, don't even run java eclasses pkg_setup
+ # as it might also die when no VM is present
+ if [[ -n "${JAVA_PKG_FORCE_VM}" ]]; then
+ einfo "Forced vm ${JAVA_PKG_FORCE_VM}"
+ java-vm-2_pkg_setup
+ java-pkg-2_pkg_setup
+ fi
+}
+
+unset_vars() {
+ unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
+}
+
+src_unpack() {
+ if [[ -n ${DIE_IF_NOT_BINPKG} ]]; then
+ die "Unable to find a supported VM for building"
+ fi
+
+ default
+}
+
+src_configure() {
+ local vmhome=$(java-config -O)
+ local icedtea6dir="${ROOT}usr/$(get_libdir)/icedtea6"
+
+ unset_vars
+
+ if [[ ${vmhome} == ${icedtea6dir} ]] ; then
+ installdir=${vmhome}
+ VMHANDLE="icedtea6"
+ else
+ die "Unexpected install location of IcedTea6"
+ fi
+
+ elog "Installing IcedTea-Web in ${installdir}"
+ if [ ! -e ${installdir} ] ; then
+ eerror "Could not find JDK install directory ${installdir}."
+ fi
+
+ econf \
+ --prefix=${installdir} \
+ --with-jdk-home=${vmhome} \
+ $(use_enable doc docs) \
+ $(use_enable nsplugin plugin) \
+ || die "configure failed"
+}
+
+src_compile() {
+ # we need this to override the src_compile from java-pkg-2
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS README NEWS || die
+
+ if use nsplugin; then
+ local arch=${ARCH};
+ use x86 && arch=i386;
+ install_mozilla_plugin "${installdir}/jre/lib/${arch}/IcedTeaPlugin.so";
+ fi
+}
+
+pkg_postinst() {
+ java-vm_check-nsplugin
+ java_mozilla_clean_
+
+ if use nsplugin; then
+ elog "The icedtea browser plugin (NPPlugin) can be enabled using eselect java-nsplugin"
+ elog "Note that the plugin works only in browsers based on xulrunner-1.9.1 or later"
+ elog "such as Firefox 3.5+, Chromium and perhaps some others too."
+ fi
+}
+
+pkg_prerm() {
+ # override the java-vm-2 eclass check for removing a system VM, as it doesn't make sense here
+ :;
+}