summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-16 08:09:54 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-16 08:09:54 +0000
commit55c0ac3507a905ac3c20f239e7e65bd6733baf6a (patch)
tree3900f91d0d166c97ed95275cdd7cc55d98957f48 /dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1.ebuild
parentminor version update to fix compilation problem (diff)
downloadhistorical-55c0ac3507a905ac3c20f239e7e65bd6733baf6a.tar.gz
historical-55c0ac3507a905ac3c20f239e7e65bd6733baf6a.tar.bz2
historical-55c0ac3507a905ac3c20f239e7e65bd6733baf6a.zip
Initial import. GNU JAXP, a free implementation of SAX parser API, DOM Level 2, Sun JAXP 1.1.
Diffstat (limited to 'dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1.ebuild')
-rw-r--r--dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1.ebuild b/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1.ebuild
new file mode 100644
index 000000000000..a81b8447f9b9
--- /dev/null
+++ b/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1.ebuild,v 1.1 2003/03/16 08:09:54 absinthe Exp $
+
+S=${WORKDIR}/${PN}-${PV}
+P=${PN/-/}-${PV/_beta1/beta1}
+DESCRIPTION="GNU JAXP, a free implementation of SAX parser API, DOM Level 2, Sun JAXP 1.1."
+HOMEPAGE="http://www.gnu.org/software/classpathx/jaxp/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/classpathx/${P}.zip"
+DEPEND=">=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_install () {
+ cd ${WORKDIR}/${P}
+ dojar gnujaxp.jar || die "Unable to Install"
+ use doc && dohtml -r apidoc/*
+}