summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-11-09 13:41:10 +0000
committerVlastimil Babka <caster@gentoo.org>2009-11-09 13:41:10 +0000
commit6bcfd71ab8ffc8befcbed1b9fb6b9cefcdb4bc0a (patch)
tree3ec1e5633df0c4c7cfa1cf62555b21da05ee290c /dev-java/gnu-classpath/gnu-classpath-0.98-r1.ebuild
parentVersion bump per bug #254441. Drop old stuff. Add x11 as backup herd. Fix als... (diff)
downloadhistorical-6bcfd71ab8ffc8befcbed1b9fb6b9cefcdb4bc0a.tar.gz
historical-6bcfd71ab8ffc8befcbed1b9fb6b9cefcdb4bc0a.tar.bz2
historical-6bcfd71ab8ffc8befcbed1b9fb6b9cefcdb4bc0a.zip
Ensure ecj has enough heap space. Fixed build failure for me.
Package-Manager: portage-2.2_rc48/cvs/Linux x86_64
Diffstat (limited to 'dev-java/gnu-classpath/gnu-classpath-0.98-r1.ebuild')
-rw-r--r--dev-java/gnu-classpath/gnu-classpath-0.98-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-java/gnu-classpath/gnu-classpath-0.98-r1.ebuild b/dev-java/gnu-classpath/gnu-classpath-0.98-r1.ebuild
index 13263a8f88ca..68ebeee5a096 100644
--- a/dev-java/gnu-classpath/gnu-classpath-0.98-r1.ebuild
+++ b/dev-java/gnu-classpath/gnu-classpath-0.98-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.98-r1.ebuild,v 1.1 2009/11/08 20:33:09 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.98-r1.ebuild,v 1.2 2009/11/09 13:41:10 caster Exp $
EAPI=2
@@ -77,6 +77,9 @@ src_configure() {
export JAVA="/usr/bin/java"
# build takes care of them itself, duplicate -source -target kills ecj
export JAVACFLAGS="-nowarn"
+ # build system is passing -J-Xmx768M which ecj however ignores
+ # this will make the ecj launcher do it (seen case where default was not enough heap)
+ export gjl_java_args="-Xmx768M"
# don't use econf, because it ends up putting things under /usr, which may
# collide with other slots of classpath