summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-01-06 04:49:30 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-01-06 04:49:30 +0000
commitddd0c85908064231c2b36424c9c9b8d57ff2ba65 (patch)
tree3ea364f0e5633d8d05eb9d072f745bd26027fec4 /dev-java/fastutil
parentMinor fix for osx support (diff)
downloadhistorical-ddd0c85908064231c2b36424c9c9b8d57ff2ba65.tar.gz
historical-ddd0c85908064231c2b36424c9c9b8d57ff2ba65.tar.bz2
historical-ddd0c85908064231c2b36424c9c9b8d57ff2ba65.zip
Version bump.
Package-Manager: portage-2.1_pre1
Diffstat (limited to 'dev-java/fastutil')
-rw-r--r--dev-java/fastutil/ChangeLog9
-rw-r--r--dev-java/fastutil/Manifest14
-rw-r--r--dev-java/fastutil/fastutil-4.4.2.ebuild38
-rw-r--r--dev-java/fastutil/files/digest-fastutil-4.4.21
4 files changed, 54 insertions, 8 deletions
diff --git a/dev-java/fastutil/ChangeLog b/dev-java/fastutil/ChangeLog
index 996b13d8db35..1209be40bb4f 100644
--- a/dev-java/fastutil/ChangeLog
+++ b/dev-java/fastutil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/fastutil
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/ChangeLog,v 1.18 2005/04/21 18:48:59 hansmi Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/ChangeLog,v 1.19 2006/01/06 04:49:29 nichoj Exp $
+
+*fastutil-4.4.2 (06 Jan 2006)
+
+ 06 Jan 2006; Joshua Nichols <nichoj@gentoo.org> +fastutil-4.4.2.ebuild:
+ Version bump.
21 Apr 2005; Michael Hanselmann <hansmi@gentoo.org> fastutil-4.3.1.ebuild:
Stable on ppc.
diff --git a/dev-java/fastutil/Manifest b/dev-java/fastutil/Manifest
index 6c5b0ca9b939..1e9abe584f56 100644
--- a/dev-java/fastutil/Manifest
+++ b/dev-java/fastutil/Manifest
@@ -1,16 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
+MD5 1ac94396e15dd7a2ac506f4839300264 ChangeLog 2004
MD5 e7ac65745e16a7e068f4d710bfc1c478 fastutil-4.3.1.ebuild 994
MD5 fd06c745c69215187c15570e3263a4ad fastutil-4.4.1.ebuild 1089
-MD5 641bf8e635a05ca9c89cab94ed593e7b ChangeLog 1882
-MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 c6c4f03734f0a623784a636693b6b964 fastutil-4.4.2.ebuild 1079
MD5 0893c05cde010685acf479a9745864f2 files/digest-fastutil-4.3.1 70
MD5 b9320721c39029bfe87e9042f7e16804 files/digest-fastutil-4.4.1 70
+MD5 e5219d7fb07c5d4cd5324495f6f437bc files/digest-fastutil-4.4.2 70
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
+Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFC17zP/rLF9B432nYRAqjMAJwJXUPHnkqNKCwbIDIC0ilXPOgtggCgjkkU
-FUfWyDXCyVqVCXlqikwUIUg=
-=HUId
+iD8DBQFDvfbindWRXhKOboURAhvpAJwJ2X2PDxko9bX865nIa8BCNBANhACgtGn7
+ALucF7/SSlyutdnCGD72Zl8=
+=NHuy
-----END PGP SIGNATURE-----
diff --git a/dev-java/fastutil/fastutil-4.4.2.ebuild b/dev-java/fastutil/fastutil-4.4.2.ebuild
new file mode 100644
index 000000000000..ebeda4fb8958
--- /dev/null
+++ b/dev-java/fastutil/fastutil-4.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/fastutil-4.4.2.ebuild,v 1.1 2006/01/06 04:49:29 nichoj Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Provides type-specific maps, sets and lists with a small memory footprint for much faster access and insertion."
+SRC_URI="http://fastutil.dsi.unimi.it/${P}-src.tar.gz"
+HOMEPAGE="http://fastutil.dsi.unimi.it"
+LICENSE="LGPL-2.1"
+SLOT="4.4"
+IUSE="doc jikes source"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.6
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4"
+
+src_compile() {
+ make sources || die "failed to make sources"
+
+ local antflags="jar"
+ use doc && antflags="${antflags} javadoc"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "compilation failed"
+}
+
+src_install() {
+ java-pkg_newjar ${P}.jar ${PN}.jar
+
+ dodoc CHANGES README
+
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc java/it
+}
+
diff --git a/dev-java/fastutil/files/digest-fastutil-4.4.2 b/dev-java/fastutil/files/digest-fastutil-4.4.2
new file mode 100644
index 000000000000..c74b5f01680e
--- /dev/null
+++ b/dev-java/fastutil/files/digest-fastutil-4.4.2
@@ -0,0 +1 @@
+MD5 e5986501c1d34eee0afd215bb3ea488e fastutil-4.4.2-src.tar.gz 213196