summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-12-09 23:15:07 +0000
committerVlastimil Babka <caster@gentoo.org>2008-12-09 23:15:07 +0000
commitda8ee6d3b070517c184f0cfbe50c91f33a65fbae (patch)
tree9993f2e5b011f2d3fcc93362aef4e9509f0cbc93 /dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild
parentPut -r0 back to EAPI=1 and do the change to EAPI=2 in revbump, for faster sta... (diff)
downloadhistorical-da8ee6d3b070517c184f0cfbe50c91f33a65fbae.tar.gz
historical-da8ee6d3b070517c184f0cfbe50c91f33a65fbae.tar.bz2
historical-da8ee6d3b070517c184f0cfbe50c91f33a65fbae.zip
Put -r0 back to EAPI=1 and do the change to EAPI=2 in revbump, for faster stabilization.
Package-Manager: portage-2.2_rc17/cvs/Linux 2.6.27-gentoo-r1-perfctr x86_64
Diffstat (limited to 'dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild')
-rw-r--r--dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild b/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..b9d5d26ced61
--- /dev/null
+++ b/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1-r1.ebuild,v 1.1 2008/12/09 23:15:07 caster Exp $
+
+EAPI=2
+
+ANT_TASK_DEPNAME="bsf-2.3"
+
+inherit eutils ant-tasks
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+# ant-nodeps contains <script> task which is needed for this
+# although it's not a build dep through import
+DEPEND=">=dev-java/bsf-2.4.0-r1:2.3[python?,javascript?,tcl?]"
+RDEPEND="${DEPEND}
+ ~dev-java/ant-nodeps-${PV}"
+
+IUSE="python javascript tcl"
+
+JAVA_PKG_FILTER_COMPILER="jikes"
+
+src_install() {
+ ant-tasks_src_install
+ java-pkg_register-dependency ant-nodeps
+}
+
+pkg_postinst() {
+ elog "Also, >=dev-java/bsf-2.4.0-r1 adds optional support for groovy,"
+ elog "ruby and beanshell. See its postinst elog messages for instructions."
+}